Robovac 11 Rotating Brush fault

I am experiencing an immediate Rotating Brush Fault upon starting a cleaning session with Eufy. It gives a solid red light and a quad-beep. I disassembled the entire system, cleaned out all the dust, hair, and the like. I confirmed the bearings of the brush spin freely and the brush motor also spins without issue. After reassembly, I got the same fault. I thought it might be a low battery voltage not able to produce the required torque to spin the brush, so I left it switched off on the charger for ~16hr. No luck.

Any ideas on what is going on? Is there like an encoder on the brush motor that might have gone bad or stuck?


1 Like

Oh! Fun observation! If I take the entire brush assembly out, it appears to work just fine, (only there is no cleaning brush).

Just reassembled the brush and toyed with the left-right slop and now it works. I’m betting there was something binding on the brush and the brush guard that prevented it from rotating. Well, hope this is a lesson that others can use. And it’s a lesson to myself that once I post a question online, I seem to find the answer myself soon thereafter.


Hi @rrieber, thank you for letting us know your concern. I have passed your problem with my colleagues, they will try to help you to solve this problem, please check your email box these days. Any other quality related problem of Eufy products, please feel free to contact via Thanks!:grin:

Hello @AnkerOfficial, Looks like this fault reoccurred. Here are the details:

  1. I flipped the unit over and masked the drop-sensors with blue painter’s masking tape.
  2. I powered on the unit and set it to autoclean. It tripped the main brush stuck fault (solid red light, 4-beeps)
  3. I powered off, removed the main brush, powered on, and started it again. Same main brush stuck fault.
  4. I power cycled it again and set it to AutoClean, this time, spinning the main brush attachment point with a screwdriver with the intent to spin any possible encoder inside the mechanism. No luck. Same quad-beep fault.

In all instances, the main brush appears to never be energized. The vacuum starts up and a side brush spins (yes, only one), but the main brush never even quivers. The time between pushing the autoclean button and the fault is ~1-second.

A side note. after I got it working on 1-June, I started tripping side-brush faults, even though they had just been cleaned. No idea why this does not appear any more. Perhaps its the order of fault detection in your software where main brush is checked first.

1 Like

Hi @rrieber , my colleague will contact you by email ASAP!!

Hello, I am having this same issue with my robovac 11 and have also taken the same troubleshooting steps to no success.

Hi @Bromando , sorry to here your having issues with your Robovac. As you have undertaken the same troubleshooting steps above I would recommend that you contact who will be able to assist your with your issue.

1 Like

I’m experiencing the exact same thing with TWO of my models, in less than 6 months (one for upstairs, one for main floor). any solutions yet?

This has happened to me a few times, and it would start working again after cleaning it out and power cycling. Now it doesn’t seem to respond to power cylcing either. This unit was purchased in mid April 2017, shouldn’t have this kind of issue so soon, I believe.
Any more advice?

As ndalby mentioned before, reach out and contact as they will be better able to assist and help with any issues. This is just a community forum to help one another

1 Like

Unfortunately, I’m experiencing the exact same thing after one month and a half of use :frowning:

Hi @Vinicius_Medina, would you please send a message to with a description of the issue and your Amazon order number? They’ll be happy to assist you with this. Thanks!

I am experiencing the same issue…my robovac gives the same four beeps when pushing button to start… I only getmy robovac to work after I move it with the remote…then it works fine untill next clean…Nothing blocked and everything is clean.

Hello, I am having this same issue with my robovac 11. I cleaned the side brushes but nothing changed. Could you help/inform me plz?

Hi @Necati_Alperen,

To best solve your problems, I suggest you directly contact They will try the best to help you.

I had the same problem and I figured it out! On the brush assembly there are two black knobs at each end. Remove both knobs from the yellow brush. You can further take apart the black knobs with a pair of pliers. After you have done so what you will find (or what I found living with two ladies) is a big old ball of hair lodge inside the little black knobs restricting the freedom of movement. Remove the hair and problem solved. Kevin (my vacuum’s name) is purring like a kitten now!


Thanks for you useful feedback!
Can’t image it was the hair caused the problem.:joy:

Simmonspaul0311, you are a genius. I was tired of having the brush get stuck in the middle of an open part of carpet without the brush actually being stuck.

I didn’t use pliers, but rather a thin flat screwdriver to pop the parts apart. Lots of hair in there, it was crazy. I cleaned that out and now the Eufy is back to what it does best: finding new and interesting ways to get stuck.

The only problem is that the parts are now loose as they didn’t have the original crimping any more and last night the Eufy was squeaking. A little white lithium grease will do, but I am afraid that will attract more hair.

This appears to be a part that needs to be routinely maintained yet was not built with maintenance in mind. I wonder if there is a redesigned part that will get around this problem. I will contact Eufy directly about that.

1 Like

I have the same problem, 4 beeps and red light. I removed all the brushes. also synonymous tutorials on youtube but nothing
if I turn it on, a rotating brush moves a little and then the 4 beeps start.
I wrote to the assistance through amazon. I hope they answer me soon because the product is very good

Hi @Stefano_Cocconcelli1,

Maybe you can also send an email to, our representative will help you sort out as soon as possible.:innocent: