Robovac 11 Rotating Brush fault

Hi @Stefano_Cocconcelli1,

Maybe you can also send an email to, our representative will help you sort out as soon as possible.:innocent:

This just saved my robovac from going in the garbage! I The drive side was far far worse than the opposite, but this resolved the issue we were having as well. We have dogs, so this thing already gets a lot of cleaning, did not anticipate hair getting INSIDE those end caps. +anker +eufy take note on these components as a weak point.

Also, the drive side cap was harder to get apart, I used a small flat head and carefully worked my way around. After seeing how it came apart in the end, it appears the drive side has a small rectangle that feeds into the motor, seems like if you can get that off first, then the rest might come apart more easily.

Thanks again! robovac saver!


Thank you for this info! I was having the same issue, kept taking the roller brush out, cleaning it, replacing it only to have the red light and beeping. So upon finding your post, we took the little black rollers apart and found more hair (mine, I have very long hair) than I could have imagined would fit inside that space! Removed it all, and it is working again! The driver side was terribly impacted. Note for Eufy/Anker: this info should be included in roller brush maintenance!

1 Like

To answer the OP’s original question, yes indeed there’s a motor in there that could be the issue.

My yellow brush assembly spun just fine in my hand, but the drive motor was so clogged with hair and dust between the pulley and motor casing that it wouldn’t turn. I thought maybe it had burned out. After thoroughly cleaning out all the gunk, it now works like a charm.

1 Like

I think this is a great little vacuum for the price, but the low price comes with a caveat…it is not resilient. I had this vacuum cleaning up floors littered by my Golden Retriever’s fine hair. Every once in a while it would stop working and I would clean out all the brushes and it was fine. But after about 2 years, no amount of cleaning would do anything to fix it’s 4-beeps and stop after 10 seconds of cleaning. In addition to this vacuum, I have 2 roombas and an Ecovacs (4 floors to my house, I per floor). I had one of the roombas roll over dog poop and had to dissect the vacuum and clean it down to it’s motherboard. I can say that dog hair never worked it’s way into the guts of the Roombas, but it is everywhere in the internals for the Ankur. No wonder the device stopped working. After 2 years of use (very good, but not great), I’m going to need to throw this model away. It keeps freaking out after 10 seconds even after and thorough breakdown and cleaning.

1 Like

I think some photos would be helpful to explain others exactly what and were you did this.

I think you can help bloggers who understand this topic.
Here are some of those I found:

1 Like

Apparently the newer model(s) (I have an 11S) are made quite differently. There is no way to separate the rubber bearings from the brush (which is not yellow) and no motor is visible or accessible without taking covers off which are nominally “not serviceable parts”.

But we have the same 4-beep problem after only a few months of use. Also, the fault happens even if the brush is removed.

1 Like

I started experiencing the same problem after about two years and managed to solve it though it wasn’t easy so be prepared to dismantle this thing down to the motherboard!

The first thing you should do is remove the brush entirely and then turn it on and attempt a clean (granted it won’t actually clean of course without a brush!). If you still get the four beeps with no brush attached then you can safely rule out that this is a brush problem.
If it cleans without the brush but beeps with the brush in, you have yourself a brush problem which you can resolve following the many tips above.

If it’s a non-brush issue, the bad news is, you’ll have to get into the guts to fix it.
Get yourself a screwdriver and carefully remove all the screws from the underbelly. What you’ll find inside is (hopefully) a load of dust/hair lodged in the wheel/brush motors and everywhere else (motherboard etc - mine was a mess). To be extra thorough I’d recommend taking the smaller screws out around the wheels/brush so that you can partially remove the motors. I “cleaned” them with my hands/fingers and a good ol blow like it’s a NES cartridge (extra points if you get that reference).

Re-assemble with patience and with a bit of luck you’ll be up and running in no time.

As before, test it without the brush to see if you fixed the non-brush issue. Hopefully you’ll be able to rule that out and test again, this time with the brush.

This isn’t for the faint hearted but as long your patient and keep an eye on everything you’ve done (take pics if you think it’ll help) you’ll be mighty satisfied when it springs back to life.

My Roomba which is two years older than my Eufy has never failed me like this. Goes to show, you get what you pay for. I’ll avoid Eufy for my next purchase!


Well done!!!
Congrats for having such a success.

As an old tinkerer and engineer :slight_smile:
I like those repairs of course.

You should have created a video for youtube.

Those issues can happen to all vaccums not only EUFY.:grin:

thanks, i’m going to try this!! (tho thinking compressed air rather than NES super mario technique!) already took apart the brush assembly with no luck, and it won’t run without brush either. and i emailed eufy support only to be told that it’s out of warranty, which apparently is only 12 months, and i got mine for mother’s day 2017. :confused:

support said i can get it fixed for $80 (what?!) or get a $30 off a new one. gonna try this and then give up i guess. first and last eufy for me, and i hate having to throw away after such a short time. a reliable company would stand behind their products for more than 12 months. thanks for all the suggestions here, really helpful!


Escalate your message with them to management and tell them they advertise 18 month warranty in Twitter…they should honor it

@megnut @elmo41683 Please note eufy RoboVac has a warranty of 12 months.

My apologies, but I swear they have said via Twitter it was 18 months. Either way I am sorry for any confusion I have caused

No worries, just clarify for you guys. :wink:

Dear all,
I am facing this problem since 1 month. Already contacted support however they reccommended to contact a local service shop in Germany which is practically not possible. I already removed all parts by myself, cleaned all motor drive from hair etc. reassembled very carefully twice. But I still get this quad beep after 3 min from start! Do you have any idea why? The machine is really cleaned now but still thinks brush is stuck. Is there mybe a reset function to eliminate this? Need really your help if someone has the experience.

Thank you all

1 Like

You could open the battery case of the robot unplug the battery and reconnect it again. May be this is a kind of reset.

Just tried, did not work either:) thank you anyway

1 Like

I bought a Eufy 11 secondhand for $35. It wasn’t that old but it had the 4 beeps problem and would stop running after about 4 minutes. I figured if I could fix it then it would be a bargain. I thought all I would have to do is clean the main brush or buy a new one but I discovered pretty early on that the problem wasn’t hair clogging the bearing on the end of the brush. I put black tape over the 3 “fall sensors” so that I was able to run the unit while it was upside down and I noticed that the main brush wasn’t spinning at all. I took the brush out and again ran the unit and I saw that the motor that spins the main brush wasn’t spinning. I tried to move it manually to see if that would free it up but no joy. So I decided to disassemble the unit to see if I could figure it out. Disassembly was easy enough. There are 6 obvious screws that hold the top and bottom together and two further screws left and right underneath the bumper. After you have removed these 8 screws you need to remove the bottom part of the front bumper. This is attached with 8 small screws. You don’t have to remove these fully from the part, just enough to release it. Once this part is removed you can then remove the bumper. Be careful and release the connector from the bumper to the vacuum to fully remove the bumper.
You can now separate the top and bottom of the vacuum. When you look into the unit, with the main circuit board facing away from you, the motor that spins the main brush is located at the bottom right. It is connected to the main circuit board with two wires (red and black). The motor housing is held in place with 2 screws, one inside the unit and one on the bottom of the unit. When you remove these two screws and unplug the connector, you can easily remove the motor assembly.
You now have to disassemble this motor assembly, it isn’t too difficult. Firstly remove the four small screws that hold the top plate in place. When you remove the plate you will find a small “toothed” belt that goes from the motor to the receptacle that spins the main brush. Inside this you will find 2 small screws that hold the plastic assembly to the motor. When you remove these screws you can separate the motor from the housing. When I did this what I found was a lot of hairs and fibres had wound around the motor spindle and this was preventing the motor from working. I removed all of the debris and the reassembled everything. One hint I would give here is that when you reassemble the front bumper, make sure it is moving freely as if it is stuck you will find that the unit just keeps spinning in a circle. I found this out from experience.
Anyway, after I had put everything back together the unit now works perfectly, no more beeping.
I know this would have been much easier if I had photos but I didn’t bother taking step by step photos as I went along as I didn’t know if I was going to be successful or not. :joy: It really wasn’t all that difficult, just take your time. One photo I should have taken was one of my beaming smile when I realised that I had fixed it!

If after you have cleaned the brush, multiple times, and you still have the four beeps problem, try my fix. What have you got to lose!

Good luck!


@Paul_Guilfoyle thanks for the write up on your fix.

If possible, can you please edit your post and separate each section into paragraphs as to make it easier to read and understand. This way if someone is working off your instructions, they can quickly see where they left off as oppossed to having to read through everything to find where they are.