Zolo Liberty+ not connecting to Laptop

So I use the Liberty+ now for over half a year on my phone. Never had any issues at all. Sometimes had it connected to my desktop PC which worked fine aswell.

Now I need to do study work on my laptop but it seems I’m not able to connect them to the laptop. I updated BT drivers and tested through “add bt device” aswell as under device manager “add device”.

On my PC it takes only one second to connect them. Whenever I try on my laptop it tries connecting for about 30s and then it says “could not connect…”

Both my PC and Laptop are on Windows 10.

I really don’t know what to do, any help is appreciated!

Is your laptop on windows 10?

Yes, updated the topic too

1 Like

Here’s my thoughts, although they are by no means, “professional”. I always have trouble connecting any device on windows 10 to any WiFi, or Bluetooth enabled device. I know I’m not the only one with this problem. I had my pc on windows 8,and everything worked fine. Than I updated it to windows 10, and now nothing works. This is a common problem with windows 10, and as far as I know, there is nothing to fix the problem.

But you should probably get the opinion of others that actually know what they’re talking about :joy:

Hmm that’s sad to hear then. I really was hoping there is a fix for that. Very strange that it works perfectly on my pc but has big issues on the laptop.

1 Like

I assume you pc is also on win 10?

Oh, I see it’s in the thread now.

I would just wait to hear from some people who know about this stuff. There are several people on here who could probably help you.

Yeah, I even used the same image to set it up.

Windows 10 has been notorious for messing with Bluetooth drivers at every update, they fix several problems but normally end up causing several more things to be effected.

Check the make of your Bluetooth module and look for an updated driver direct from there website (not Windows update)…often resolves 80-90% of BT issues mentioned on here with Windows 10…


Sadly already did that. Updated to the latest drivers from manufacturer’s site.

What do you have listed under Bluetooth in device manager, any references to a previous pairing of the Liberty+?

No, they’ve never connected to my laptop since I tried.

Please try and reset the liberty+
Complete the following to reset:

  1. Put earbuds back into the charging case and then remove them…
  2. Double tap both earbuds simultaneously
  3. Select Liberty+ within your Bluetooth menu

Replace the bluetooth driver given by WIN10 with that of the manufacturer of your bluetooth device built in the laptop.

Already using the manufacturers driver. And I already resetted the earbuds, sadly didn’t help.

You should tell us the manufacturer of the Laptop and the built-in bluetooth device.
As they ear buds work with other devices I think they do work properly.

I am not familiar with WIN, but there should be a “deeper” look into the bluetooth protocol possible,

I have Liberty (not +) and they too have issues connecting to Win 7 laptop. I have to tweak the services to make it work. It is definitely not easy for normal users.

I was searching if MS offers something usable for bluetooth trouble shooting.
I found only the typical useless blablabla. :angry:

So if he has installed the original manufacturer’s driver, there must be another issue.

So you might give him hints what to do!

I can try…
In win 7 - go to bluetooth devices list. Find liberty+ and then right click on it.
Go to properties, then click on services.
There make sure the serial port is enabled. Sometimes you may have to edit serial port (convert 4 to 3 for example).
Once done it will automatically download the required drivers and will work correctly.
I don’t have win 10 so cannot say much about that. Process should be similar though.

Well I can’t right click liberty+ as they’re not connected. Do you do that under “bluetooth devices” or in device manager?

Laptop is the xiaomi mi notebook pro with drivers from their homepage