Unable to add Homebase 2, help?

What a piece of crap!
I’ve been exchanging emails with Eufy support. They requested videos but they are clearly aware of the problem: " We encountered the same issue as yours".
Unfortunately, the solution is to keep trying, and I didn’t nought a roulette, so I’m following the thread I mentioned above and return it.

This is super frustrating. What does the blinking light mean? And I connected to the internet or not? I’ve followed all the steps, reset, tried the same thing as every other post here and still no luck hours later.

1 Like

Did you contact support?

I have the same issue. This is getting sent back, wasted too many hours already. What a pile of crap and I’ll be writing such on Amazon.

Yes, and they told me my mesh network meant I couldn’t use it.

Support told me the fact that I had a mesh network meant I couldn’t use the Homebase 2. But, when I connected right to my modem, I was able to add it no problem. Just had to change my network settings. Once I got it connected, I changed my network back over to my mesh network and then changed the HomeBase to Wifi. It works now!

1 Like

The Homebase can use a mesh network, it’s just a network.

But Homebase to camera can’t, as far as I know so the product in total can’t use mesh, as far as I can understand.

So a mesh may help out the Homebase further away from router / modem but not likely with the camera to Homebase.

Did I get that right?

I don’t understand it enough to be honest. All I know is that support basically told me “Homebase 2 will not work with a mesh network”. Then, I refused to believe that was true and fixed it. I now have a bunch of Eufy cameras hooked up to the HomeBase on my mesh network without issues.

As I understand it, Homebase to camera does not use Wi-fi, it does use 2.4Ghz. Homebase can use Wi-fi to network.

When Eufy says doesn’t work with mesh I think they mean you can’t have a long distance between Homebase and camera mitigation via mesh.

But you can connect the Homebase to any WiFi network once setup, including to a mesh.

We’ve had a lot of threads where camera cannot (reliably) connect to Homebase due to distance / walls and wouldn’t benefit from mesh. We had to suggest other methods like Powerline or mesh to move Homebase nearer to camera.

I mean… I was standing right next to my router and was wired. So, I really didn’t understand why it wouldn’t work. But, I’m just happy it works now.

1 Like

2 days ago I installed the eufy doorbell (battery) with homebase 2 as described in the manual. It worked fine right away.
After 2 days the power went out at our home and was restored after 1 hour. After this I could no longer request images (error -21), despite the light being solid blue. I then reset the homebase 2 and tried to install it again, but cannot connect to the homebase 2 through my phone when installing.
All checked below:
1 Please make sure your router has internet access.
2 Please make sure your HomeBase 2 has booted up and the LED is blue.
3 Please make sure you have scanned the QR code on the bottom of HomeBase 2.
4 If you are unable to scan the QR code, you can manually enter the code.
5 Make sure you click the SYNC / ALARM OFF button located on the back of HomeBase 2 when you heard the sound tip.
6 Please check if you have set the firewall or whitelist in your router.

Homebase 2 is blinking with BLUE color light.
Homebase with ethernet cable direct to the same router as where my wifi signal comes from.
QR code scanned, OK
Also pressing the sync / alarm button (long or short) after message does not help
WiFi is 2.4 Ghz
Mobile: Rebooted my phone couple of time, reinstalled the app couple of times. None worked.
Device: On / Off Homebase2, reset, pull-out the power line and plug-in. None worked.

Thank you for your response!
Paul van de Kamp

Hi Paul,

Your story is exactly like mine.
I almost think that it’s a server problem, like a process hanging at the anker servers.
I installed mine thursday got a power outage yesterday and not able to add the homebase with a blue blinking led.

I have sent my message to the helpdesk support@eufylife.com I am very curious about their response.

Same problem.Helped me reset with pin hole on back side.

So I think this may be an issue that the Eufy server was down by coincidence when you had a power outage.

If there is a power outage then best during the outage to turn everything off and ideally unplug anything not heavy duty (so everything but the refrigerator, heating, etc).

When the power is restored there is a power spike followed by a brown out when the heavy duty items come on. This can leave non-heavy-duty items in a confused state.

If you didn’t unplug the items during the outage, if they are confused, then:

  • turn off everything including router.
  • turn on router, let it connect, settle down
  • turn on any homebase, settle down
  • turn on everything else, settle down
  • wait
  • if the service doesn’t come back up, small chance the outage locally by coincidence the service is down.

I think what happened is coincidence the Eufy servers were partially down, the authentication server was down so you could not add at the time. This is why delete and add is not always the best idea, you force an authentication, it’s can be better to wait.

Most services don’t force authentication each time as that forces a long outage recovery, they do an infrequent authentication then cache a token in memory and most units will reconnect using the token.

So don’t always delete re-add, often wait.

support replied to me that i should test it again because of a network outage.
Still blinking blue led, even after a reset using the pinhole.
Replied that it still isn’t working.

There is no valid technology reason for such a long outage.

Either they went low cost in architecture or inexperienced architect.

There are good reasons for a few minutes of outages but not hours. The best architecture can get outages down to around a minute.

New firmware for homebase2 today!!!Problem solved!! And rmy cameras has been long distanc for trnsmision.From 1 to 2-3 bary .

I am very dissapointed in the support from anker.
Yesterday morning they asked me to try again because it should work, it didn’t.
immediately i responded that it still didn’t work. At the afternoon i called the support line asking what could be done, she told she would put engineer on it.
This morning i had an e-mail to send a small movie clip of the error and the serial number (had already given twice). This morning i made the clip and suplied the number, no response, video hasn’t been watched yet.
If it isn’t fixed tomorrow i definitely going to send back the doorbell and base.
One and a half day working, 3 days downtime…


I have the same problem. The cameras worked until the failure of the Eufy servers 2 weeks ago. Since then I try to reconnect the Homebase with the app without success. I have meanwhile replaced the HomeBase, but continue to have the same problem. I have tried the tips here and it tried at least 50 times without success. The Anker support was not really a help except for the exchange of the HomeBase. Is there another tip? I use a Fritzbox and an iPad or iPhone.

Thank you very much.

Many greetings Markus