Soundcore life Q20 not turning on

I cannot turn on my soundcore life Q20. Bought them 2 months ago. While charging, red light remains on. Also I tried checking the charging current and voltage with my usb current meter. It shows 5v with 0.05A charging current. Tried 3 different cables along with different wall outlets too.
What can be the problem?

1 Like

Please try changing the charger you use to charge the Life Q20, looks like either it is not charging well OR battery has issue.

Life Q20 needs 5V at 0.65A and takes around 3 hrs for full charge. Try charging with a different charger.

Also reach out to SoundCore support at service@soundcore.com

1 Like

As @Shenoy mentions, rule out the charger, stranger things have caused problems.
I have the Q20 and am not aware of any reset option, I even trawled the internet.
You could try returning to the retailer os contacting Soundcores amazing customer service - details in Shenoys post.
Let us know the outcome @Haris

1 Like

Well. Tried different chargers too. Not working still.
[update] I randomly figured out how to reset these too. While charging press the volume up button plus the power button for 5 seconds. Blue and red light flash alternately supposedly indicating a reset.
But even the reset didn’t help.

1 Like

Do this first —

Keep your purchase proof handy, in case for further resolution.

Shame mate.
Support will, erm, support you :+1:

We are sorry to hear your headphones are not working properly. According to the information you described, the issue you are experiencing is very unusual.

Don’t worry, please don’t hesitate to contact us at service@soundcore.com by detailing your order number and the problem you come across. We will reply you within 24 hours.

@ndalby @TechnicallyWell this post needs to be in Q&A section, can you please move it (guess so)

1 Like

Post moved to Q&A. Thanks @Shenoy!

1 Like

thank you Sir!

I cannot connect my Soundcore life Q20 headset to my MacBook Air. It worked a few weeks ago, but then stopped connecting. I can still use it with my iphone. It is very frustrating as this is a replacement. The first one did not charge… Anker Support were good in sending replacement, though received after very long…now I have this connectivity problem. Can someone help me please: I am not a techy…but a prof now doing a lot of lecturing online.

Same Here… Any Solutions?

Same issue here. I’m part of the “very unusual” club. On my third set with the same issue. Cannot even update the firmware because the battery is too dead to be recognized?

Best to reply to 1 best thread not 4 to focus a reply.

Thanks Professor, I’m sure which was the best thread. Since all four threads parallel the same issue that I’m seeing, I thought I should comment to amplify that the problem might not be as “very unusual” as Anker Support thinks it is, and to provide affirmation to others with the issue that they’re not alone or at fault.

Commenting on all four also increases the chance that I’ll get a notification if someone in any of the four threads comes up with a solution, right?

Same issue here, with a brand new device.

If its brand new, its under warranty.
Write an email to the support.
By the way is it full charged?

I came here in search of an answer to a similar if not the same problem. I fixed mine after tinkering with it a bit. I noticed the volume up button was stuck pressed in. Somehow either I pressed it too hard or bumped it causing the volume key to stick. I used my fingernail and popped it back up. They turned on fine after that. Check your buttons to see if it sticks. Must cause them to not turn on for some reason if a button is stuck. This may or may not be the case with yours good luck.

I’m sorry, but I’m here because of a Sim lar problem, I had my sound core q20 earphone connected to the TV and to my cell phone. Then I unlinked it from the TV and now it doesn’t work, it only has the NC light on and no button responds to me, also it doesn’t work with the cable either. Any idea what happened.

Do a full charge.
Remove the headphones from BOTH devices’ bt lists, you made a connection to.
Then do a reset on the headphones and start the connection again.
There could be a conflict by connecting to multiple devices.
But I dont know, I am not the support.:grinning:
If this doesnt work a message to the support could be helpful
Add all “numbers” you find on the box of the headphones.
This might shorten the process a lot.