Soundcore Liberty Air 2 right earbud not charging/connecting

We have the same problem. First it happened to my husband a month ago and right now to me. I think it’s a manufacturer’s issue.

Same problem. I just brought worked for 10 mins now the right ear not even flashing lights. So frustrated.

Have you shone a flashlight deep into the case to check pins not got debris? Also check the bud.

I do wonder how many users didn’t take the plastic off the bud before putting in case.

resetting box with pressing 10 second and then long press to button that not charging earbud can solve problem. Solved for me.

1 Like

Hi I have the same issue. Any suggestion or DIY to fix it?

1 Like

Sorry to hijack the thread. But I am suffering the same problem. However, I bought my buds refurbished and they are out of warranty. What can I possibly do? Any help would be appreciated!! Thanks

I had similar issue with my right earbud. I tried to clean both the earbud and the charging port but wasn’t working.
Then I used alcohol solution to clean the earbud and the charging port. Then the right earbud started charging.

1 Like

Worked as well.Thank you very much!:*

Try cleaning the pins on both the buds and inside the case with q tips and 91% rubbing alcohol. Mine did the same thing this morning and after doing that they work great. The pins aren’t making good enough contact.

1 Like

I bought these three-four weeks ago and I’m fast nearing the end of my tether. I’ve had problems with connecting the right earbud since the beginning - the right earbud will not connect, and I have to reset them as instructed on the Support page. I’ve also updated the firmware to the latest version. Previously, removing the bluetooth pairing from my phone, resetting them and re-pairing them resolved the issue when they occurred, so it was just a minor irritant.

But starting this weekend, resetting is getting more and more difficult (I do not get the red flashing light after 10 seconds, on either of the buds) and only after leaving them overnight and then spending 30 minutes fiddling with them on Sunday could I get them to pair again.

Then, on Monday, the right earbud had not charged even though it had been left plugged in over-night so I couldn’t use it in the morning. I left it charging all day at the office, and managed to use it for about 3 hours in the evening. On the Tuesday, the battery was quite low and it lasted through my morning run but died as I was biking to work. Now I’ve been trying to charge it here in the office for the last 4 hours but it’s still showing only 10% when I pair it.

I’ve just cleaned it as best as I can here in the office, with a pencil and an alcoholic, antibacterial wipe wrapped around a pencil. If it doesn’t improve after this, I’ll be demanding a refund.

It’s a shame, because I genuinely like the product when it works. The sound is amazeballs for the price, and it’s got a good set of features (even though the bloatware app could be done away with). But the quality just doesn’t seem to be there. I bought them on a recommendation from a friend, but I should have googled a bit more beforehand, since these seem like endemic problems that have plagued the brand and model for years.

I’ll keep documenting here, because it might be useful when requesting service/refund.

Two hours after the previous post, the battery level on the right bud has gone from “low” to “medium”, but now it won’t connect instead. It turns on with the standard start-up sound and states battery level, but when I tap it on the list of available devices, I just get an error “Could not connect to Soundcore Liberty Air 2”. Tried 3 or 4 times and chucked them back in the case.

It doesn’t seem like they turn off when they’ve been put in the case - they stay on and show in the list of available devices (but can’t be paired with). Only after about 5-10 minutes do they actually turn off. At the same time, they do not automatically turn on when they are taken out of the case again, but have to be started up with the touch button.

Having another crack: this time around I’ve started the right one up and am scanning for available Bluetooth devices - but now it doesn’t even appear in the list. After a while, they turn themselves off with a little sound sequence. Start them again with the touch button - still do not appear as an available device (it is possible they are appearing but without their name - there are a couple of unidentifiable devices in the list).

Back in the case again (sigh). Tried to reset and this time around I did get a flashing red light on the right one after 10 seconds (though not on the left one).

Take 'em out and try to pair again (they are not in my paired list since I removed them at the start of this).

They still won’t show in the list of available devices (at least not under the model name). Tried turning on the left one instead, just for a laugh. That one both gives the sound indication that it’s in pairing mode, and appears in the list. I can even pair with it, but not with the right bud. Pressing and holding the touch button produces one quick tone (“bom”) but no further auditory feedback, and it doesn’t appear to do anything - at least it’s not visible anywhere on my mobile.

Ok. Getting a little frustrated now.

Put them back in the case. All 3 lights on the case comes on for a few seconds. Then the left and mid light stays on for a few seconds more, while the right one fades on and off. Then all three come on again, only to go out again. This all seems very random to me. Open the case, hold the reset button down for 10 seconds, 20 seconds, 30 seconds. No lights at all, on either of the buds - no white light, no blinking light, no red light. Close the case again. The three lights on the case still come on and off, at about 3 second intervals.

Take 'em out again. Get another anti-bac wipe out and clean the connectors - I haven’t got rubbing alcohol so doing it as best as I can. I notice as I’m cleaning the case that the left one is flashing very rapidly, whereas the right one is fading in and out at a slower pace. Then the left one flashes red and goes black. The right one has gone black as well, now. They do not appear in my mobile’s bluetooth list.

Pop them back in the case. No lights, until after about 10 seconds when both come on a solid white. The left one goes out again after 10 seconds or so, the right one stays on. Then the left one comes on again. Are they sentient? Is there some tiny intelligence, trapped as a ghost in the rather wonky and useless machine? Who can say!

They’re staying on with solid white light for a good while. Eventually the right one goes out, and then the left. Then they come on again. They still don’t appear in my bluetooth list on the mobile. But maybe that’s ok, since they are still int he case.

Turn off bluetooth on my phone, try to reset the headphones again. The left one resets, I think (it flashes red anyway). The right one stays stubbornly, I think a little churlishly, dark. I can pair the left one, no problem. But the right one won’t work.

Tried again to reset the earbuds, this time pushing the right one hard into the case as I was holding the reset button. Nothing happened for about 30 seconds, but then it started flashing rapidly, and as I let go of the button, it briefly flashed red. Now it pairs! Finally!

Let’s see if it will still pair tomorrow morning, when I will want to use them again.

They’ve been plugged in to charge in the mains socket for 12+ hours. The battery is only at 10%.

I can’t be arsed with this anymore, these are going back for a full refund.

It is good to share experiences so future searches find.

But if you want actual support from Anker, there is a dedicated Soundcore forum where Soundcore staff read.

No-one from Anker / Soundcore reads here (that we have noticed for year+ )

1 Like

Im having the same problem

My right earbud stopped working and couldn’t connect to my phone then I wiped the charging port with alcohol and it worked.

1 Like

I’m experiencing same trouble - afrer 6 months of perfect functioning right earpbud of my Soundcore Liberty Air 2 Pro stopped charging.
After cleaning/resetting etc. i got what issue is in charging box - and in my case reset of the box helps for a while - it charges both buds once. To reset box only (not the earbuds) you can put it on charge with charging cable.
Looks like a trouble with wake up from power save mode one of microcontrollers in charging box or its firmware issue.

I’ve been experiencing similar problems for months now - earbuds not charging and having troubles with BT connection. The problem seems to be entirely connected with a fact, that the pins that are supposed to charge the earbuds are hidden deep in their respective wells, making them prone to getting very dirty very quickly. Due to that, earbuds are not charging and the software disallows connection.

However, I think I found a solution - the pins inside need a very vigorous scrub using alcohol (I used 99% IPA) and a q-tip that you use to clean your ears. You have to put your heart into it and really try to scrub the dirt that is on the pins. After that, the buds connected without a problem. Hope this helps.

So im having the exact same problem and think i know the exact casue after plan A-Z.
If you look at the left charging base in the case, you see the order is pin, circle, pin. The circle in between the pins protrudes out a bit to make contact with the corresponding flat circle on the earbud.

I just noticed that on the right side, the circle isn’t protruding like the left, it’s actually flat, flush with the casing. Thus, I’m assuming, the pins make contact to tell the case a bud is has been inserted but the middle circle in between those pins is what charges since it’s magnetic. If that magnet cant connect to the bud then it isn’t making contact to even charge the right earbud.

The fact that everyone is having the same problem I’d check the case out. If it’s all the same EXACT problem as me, there needs to be a recall and replacements need to be given.

I noticed this issue after I dropped my case on concrete with the earbuds in them, and the right earbud wouldn’t work. I tried cleaning the connection pins and the right earbud would not respond to me holding the button on the case and wouldn’t flash red at all. I then tried dropping(only) the right earbud again, and now it works? :woman_shrugging: