Soundcore Liberty Air 2 not disconnecting after I put them in the case!?

This just started to happen yesterday, whenever I’m done using the headphones and I put them back in the case they do not disconnect from my phone (unless I turn off Bluetooth or shut the headphones down manually by long touching the sensor on the buds). This just causes the battery to drain and it I want to listen to something on speaker I’d have to turn Bluetooth off.

This wasn’t the case before, until now they were working perfectly and they used to disconnect as soon as I would place them in the case and reconnect as soon as I take them out.

Can someone give a solution? Thanks.

1 Like

Give the charging ports a good cleaning, and when put into the case make sure to push them down and close the lid. Within 10 seconds of doing this they should disconnect from your phone.

So clean the charging points and also make sure there is no debris inside the case blocking the charging pins

1 Like

I tried this but no luck, is there a specific way to clean the port and the case? I might have not done it properly maybe…

Mine just started doing the same thing. That’s disappointing.

Contact support if the problem persists

I had the same problem when I changed the ear and wing tips. Make sure the wing tips are on correctly. They should by flush by the bump out part, not sticking up, there is a little notch and a hole on the wing tips, line them up. Yes and wipe off the pins, but that fixed it for me. If not the way to hard reset them is to put them in the case, make sure they are charging, leave the lid open, press and hold the button on the back for about 10 seconds until they flash red 3 times. Then they are reset. Good luck.

In reply to everyone, I tried all suggestions and no luck. The right earbud is staying powered on and taking a charge simultaneously. I’ve reset and reset all Bluetooth connections and I can still see it when I scan with it in a closed case.

Same problem. First month everything was fine. Than problem starts appear from.time to time. Now it is consant issue. Very disappointed with my purchase!

To everyone with the same problem finding this thread: Make sure that the case does have a charged battery. That was the problem I had, I had not noticed that the battery was empty and was wondering why the earbuds would not disconnect and charge when i put them into the case. As soon as I plugged the case in to charge, the earbuds disconnected and started to charge as well. I hope this helps someone. Have a nice day!


Same issues! It’s getting very frustrating, every time Im done using the buds , I hav to turn off the Bluetooth manually in order to disconnect the buds, disappointed.

1 Like

The same here. I cleaned the pods, the case (bassicaly they are new, so very clean). After i put them back in the case, they disconnect from the phone (ios) but after a couple of minutes they seem to reconnect. Does anybody know how to solve this issue?

I’ve just had this problem two days after purchasing them. I did the “case reset” mentioned above and that seems to be working. If it re-occurs I’ll report back.

Such a weird issue

Problem is back less than 12 hours later. Such a pity. Will get on to support.

Make sure there is nothing blocking the charging pins, even a little bit of lint or dirt can stop the connection. The earbuds should flash and blink a white light when placed back into the case, the case also needs to have a charge otherwise the earbuds will not disconnect from you phone as the charging pins is what turns them off.

1 Like

I had this exact problem. I reset them several time and was about ready to throw them away and buy a new pair. I noticed that one of the electrical contacts was black when it is suppose to be golden and shiny. I took a q-tip and cleaned the contact on the earbud and the contact in the case. It immediately started working correctly and has been working fine since then. I think the case wasn’t recognizing the earbud was in the case. That’s why is wasn’t disconnecting from my phone.

This is a thing. These earbuds simply don’t work well with iOS. Tried on both my wife’s iPhone and mine. Latest firmware for the buds, and latest iOS. What an obnoxious issue at this price point. Soundcore needs to test their stuff better, and on more than just Android devices :wink:

Returning them. Sucks, because I really wanted to love them, then this comes up 3 days into using them.

I’ve had mine for a little while now and even talked my dad into buying a set! For a while I was amazed with the quality and sound and comfort. I’m a 12hr night shift fabricator/metal worker. So I need a set that have good batt life and also that blocks outside noise but doesn’t hurt after a couple hours. I was so happy to find these even if they were a bit pricey… long story short for the past couple months I’ve been having all the same issues as you guys. And give us people some credit here, we aren’t idiots lol I’m sure the first thing everyone has tried is cleaning the connector pins lol. None of it works and now I’m unsure if I want to buy a second set since these didn’t make it 4 months before the issue started.

I’ve been in this line of work for a long time so I’ve tried many different types and brands of ear buds. So far skull candy is the only other brand that delivers on bass and longevity imo. I’ll be going back to them of I can’t find a repair solution or a fix for these. Good luck everyone!

And one more thing I’d like to point out I noticed. When both buds are in and charging they light up once they connect. I’ve noticed while mine are showing connected they still play so I’m thinking it’s possibly a software issue. Like a screw up in one of the updates. Just a thought maybe someone with more brain could investigate more how these behave when hooked up vs not.

Same issue. Started happening within the first hour.