Powerconf C300 firmware upgrade fails

Hi all,

I’m having an issue getting the latest firmware installed. Current FW is 1.31 and shall be upgraded to 1.42 using the AnkerWork software (V.0.0.18) in 32 bit. My PC is a 64 bit Intel-CPU laptop with Windows 10 Home (20H2) and 32GB of RAM.
Everytime the FW upgrade gets started, after 1 or 2% of progress the camera gets disconnected from my PC and the software eventually goes in a unresponsive mode. I switched of my anti-virus but still the same problem.

Is there any FW upgrade software available other than the AnkerWork one?

Best regards

Do you have any other laptop from which you can run the firmware upgrade? Reach out to Anker Support Support@anker.com and provide details on the laptop make / model, complete windows version

Newer operating systems do have the option to use 32-bit applications on 64-bit architecture so please @Oliver_Bender_Oliwor
Follow This Guide on how to enable the install of 32 bit applications on a 64 bit operating system.

1 Like

Apps should be installed and run, irrespective of its 32 or 64 bits on Windows 10 64bit machine.

I have the app running on 64bit windows 10, and did not have to do any of this for the final release application. and since it is windows, updates can cause issues (and also resolve them :smiley: )

Mods: move to here

Thanks for all your help. Indeed I could solve it with another PC. Firmware is now on the latest version. This thread can be closed now.

Best regards

1 Like

I upgraded my firmware and now the camera is unresponsive. I’ve rebooted and tried other computers. Suggestions?

My C300 appears to be bricked - says “Initialization Failed” in AnkerWorks App on MacOS. Software can tell that C300 is connected but no video and sound and “Initialization Failed” message when ever I try to run AnkerWorks App.

What procedure am I supposed to use at this stage?

Thanks for your help, Rick