New EufyCam - Error When Adding HomeBase


I’ve just received my EufyCam set, and am in the process of trying to set it up. Both the HomeBase and my phone is connected to the same WiFi router. The Eufy Security App detects the HomeBase and shows the serial number, however I get the error message “Fail to Add (-997) No P2P DID String”.

I have tried both iOS/Apple and Android with the same results.

The HomeBase LED is flashing white.

Rather ironic that I received it on a weekend when isn’t at work. :frowning:


1 Like

Same here i just received it today 11/17 trying to add says it has been added, then says on iphone to add a homebase name but nothing happens the confirm button is grayed out and with a spinning wheel. I have tried it like 10 times same results. Not cool.


I’ve got a thread chatting with Brian over on the Kickstarter “Comments” section, and he’s also having problems with initial setup also. I’m not sure where the best discussion location to get a response out of Eufy/Anker.

I don’t feel that it’s any problem with our individual network setups, I really feel that there may be a problem with Eufy/Anker’s cloud systems that support the camera system.

I’ve done some packet captures, and there’s minimal traffic from the HomeBase out what I think is the Eufy/Anker cloud systems hosted with AWS.

My eufycams has been offline for the past 2 days now. Numerous router and wifi extender resets as well as HomeBase resets does not correct the problem. My other two security cameras ( Foscam and AnkerCam) are working fine so I know it is not my network.

I’m thinking the culprit is the last HomeBase update that is causing all the problem that I have been having with this security system.

1 Like

Thanks for the info @deeznutz.

That does give us some insight into the non working nature of our HomeBase. Hopefully someone from Eufy/Anker will chime in and let us know what’s wrong. I’m hoping I’ll get a reply to the e-mail that I sent to

I was chatting with you about this over on the Kickstarter but wanted to chime in here in the off chance that someone official happens to jump in and actually offer some insight into what’s going on and how we can all resolve our issues when adding the HomeBase.

As said before, I’m experiencing the same issue. When trying to add the HomeBase on the app, it never recognizes that there is a HomeBase to add, despite both the unit and my phone being connected to the same router. The app offers no troubleshooting steps other than verify that both the device and phone are on the same internet connection, which makes it frustrating trying to figure out why it won’t connect. I’ve tried restarting my modem, router, phone, and the HomeBase, all with no change. I even swapped in a different data cable in the off chance that the provided cable was bad, and again, nothing.

The light on the HomeBase goes from a solid red light to a blinking white light. The setup instructions are not clear on if the light should be blinking or not.

I’m wondering if there’s some sort of firmware update that is either being installed, needs to be installed, or had an issue while being installed, that might be blocking the unit from talking. That or a change in version number on the app is crippling the connection.

1 Like

I know you all are fairly new here, so some insight about Anker/Eufy they generally don’t work weekends and they rarely answer emails over the weekend. But rest assured they will respond and get back to you as soon as they can.

Sorry about the troubles everyone is having, but they will get to you and help y’all out.
@AnkerOfficial @AnkerSupport


@Peaden Same thing this morning for me too. Same error. Still awating someone official to reply. Totally agree with you on the unclear setup instructions! Hopefully they improve them as they are released to general sale.

Interestingly, this morning when I was in another room I heard the HomeBase say something. No idea what it said because I was far away. I hadn’t touched it since last night.

Thanks @elmo41683, totally understand that they don’t work weekends. Timing was just horrible with receiving them on a Saturday. Looking forward to hearing from @AnkerOfficial & @AnkerSupport

Can anyone who has already successfully set up their EufyCam HomeBase say whether the blinky light on the front should be blinking white or solid white. Thanks!

Blinking white light means it is waiting to pair/add a device. Solid white light means it is on standby.

My HomeBase is showing solid white light but the Eufy app show everything offline. So frustrating. It is basically useless since Friday.

1 Like

I had to restart home base during setup and run through setup 2-3 times. I believe it gets an update first and interrupts the setup process. I also deleted and reinstalled app and let homebase sit for 15 min after rebooting it before trying again. I could be wrong but it’s what I did

Also, the cams don’t use your wifi network to connect to homebase, they use a proprietary low energy wifi directly to homebase to save battery juice.

Homebase seems to reboot after firmware updates in middle of night sometimes and says welcome to eufy security when booting back up

what is your firmware version on homebase?

in app go to my devices -> homebase ->device info -> software version

Thanks for the info @bill_rae. I’ve not actually been able to get as far as pairing my Home Base with the App. So I can’t tell what firmware version its on.

ahh ok, hopefully they answer you today

So after try umph times. This is what I did and it is up and running. I would setup as the instructions says, the HomeBase says connected, then you would put in a name for your homebase. This is where it just shows the “confirm” button grayed out. I closed the app (I am using an iPhone). Went back into it and it showed the HomeBase was actually added, I then added the camera and that too was added. Seems to be working very good, I like it.

The video timing is short, I was reading you can select from 5 to 300 seconds for recording but I haven’t found where to make the change.

I mounted my camera on a tree facing my home. I like the speaker and mic feature works good, a little delay I guess that would be expected. Video quality is good.

I just would like to know about accessing past videos and if I can setup the camera so I can view it with Blue Iris.

Hope this helps, and it you guys/gals have any input let me know as well.

Hi @ExpressNV glad to hear that you made some progress. I’ve been going crazy trying different things to get my HomeBase paired. I’ve gone so far as to try it at work (different WiFi router etc.). With no luck! :sob:

I actually heard back from support, but have nothing new to say. They basically asked what phone I was using and what the app version number was, as well as the serial number of the Homebase. Haven’t heard anything since then.

From what I’ve gathered both here and on the Kickstarter, the white light should not be blinking. As for why it’s blinking is open to debate. Either it’s installing an update, it’s trying to connect to a camera, or something else entirely. How you can tell what it is doing and when it is finished is undetermined.

Again, Eufy should really include some better instructions on how to setup and troubleshoot their app and their equipment. It’s all guesswork and at the rate they’re going, it’ll be days before we get anything that even resembles a solution. With a holiday coming up, I probably shouldn’t expect to use the equipment I paid for until December.

Yay! I spoke with Ashley in Customer Support. I must say that Anker/Eufy have some of the best support I’ve experienced. While my problem isn’t solved yet, at least we’re digging deeper into what may be causing it. It may be because of Geo-Location, which goes back to one of my comments where I said that it may be with the Eufy cloud system. Looking forward to hearing back from the engineering team. Thanks Ashley.

1 Like