"Unable to connect to application server." and phone and chat supports are down... What the flying f***?

We know this is super frustrating and we are working hard to get everything back up and working. We designed the Eufy App to connect to your security devices from anywhere (in the home and when your out and about). Because of this, the App does need the server up and running to access recorded video (Events). We will be providing detail as soon as we can know more. In the meantime, again, know we plan to learn from this to make sure it doesn’t happen again.

We are sorry for this. Our team is working to get our servers back up. Although your footage is saved locally, the App needs to be able to talk to the devices so you can see recorded footage both in the house and when you are out of the house. Because of this, the App does need the server up and running to access recorded video (Events). Live video doesn’t store video, so isn’t being impacted by the down server. We will be back soon more more as soon as we know more.

We are on it!

I wish we could say something to change your mind, and give us another chance. But we understand this is frustrating and that we need to fix this problem. We need to do better! We will be providing updates as soon as we get them.

Yes, this is super frustrating. Apologies don’t help a lot right now, I know, but please know we are trying to fix this as fast as we can – and learn from these mistakes so we sure this doesn’t happen again. What we can promise, is doing better to communicate. We can do better, and we will. (Eric on Behalf of Eufy Security).


We 100% agree. We dropped the ball on communicating as we focused our attention on fixing problem. We can do better and appreciate you taking time to post here. We will provide more detail on this outage soon! (Eric on behalf of Eufy Security)

Hang on, that’s unfair.

If you see above I am critical, but there is no subscription you have to pay for. This is just bad architecture.

You also get what you pay for. They have stated they store only metadata centrally not data, which explains the cost and no monthly fee.

The service requires centrally servers to access your local data. They didn’t have to architect it that way.


We know this is really frustrating. We are working to figure this out and will be back soon.

We 100% agree. Our communications was terrible. That we can fix NOW while our teams work to fix the server-side issues. On behalf of Eufy Security team, we promise to do better! (Eric on behalf of Eufy Security)

1 Like

Shit you guys are lucky you can view your cameras…

nothing pops up for me anymore. Day 3 with these and two days the servers have been down.

We are getting reports from product team that servers are slowly coming back up. There may be intermittent problems for a bit. Please refresh your app from time to time to see if things reappear.

We are getting reports from our product team that servers are slowly coming back up online. There may be some intermittent issues with connectivity, but please refresh your app from time to time as you should soon reconnect to app and video events.

It does appear to be back up and working. I can get notifications and I am able to see events again.

1 Like


1 Like


Certainly is. Critical information about downtime and updates needs to be pushed from the provider to customers (i.e. in-app messages and email to the customer’s registered address), not the other way around, with customers going looking for information.


My inquiry to eufy was re: dependency on eufy servers for video access/recall. Response below:

Thanks for contact us.

We appreciate your support with eufy and please be assured that we always take customer satisfaction and user privacy as our top concern. Having more and more users worldwide, the server needs upgrades to accommodate the expanding scale. For better user experience in the future and for system maintenance, we were performing a system upgrading but unfortunately, some users were unable to use the eufy security app as normal. So sorry for the inconvenience caused. The concerns that arose in this issue will be documented for internal improvement and to ensure that the same issue won’t happen again in the future.

The video data is encrypted and saved on local HomeBase indeed. Video data streams directly from HomeBase to the eufy security app and the communication between them is carried out through the P2P connection. Nowadays, remote access is mandatory for most people. Therefore, we have developed the architecture starting from this demand. The App relies on the server as an address book to find the HomeBase and locate the video. We think the key concern here is whether the video data is uploaded to the cloud. No worries about it! Users’ videos are all kept in the Homebase, only users with the correct eufy account information can get access to those videos.

Hope that helps and do not hesitate to email us if you have any other inquiry

1 Like

I was previously getting the “application server” errors in the app, at various times during the past week, but the app would stay logged in and I could still view the live stream from my video doorbell.

As of this morning, I’m logged out and can’t log back in. Live stream is still available from eufylife.com, but all events, ability to respond to visitors, etc. is gone without the app.

[EDIT] - holy shit, I just realized that the date on this thread is JUNE 12, not july. I thought they’d been having server problems for a week, but it’s been a month!

July 15, 2020, customer support advised that I download the latest App version is (V1.8.1).

Errors have subsided quite a bit since update.

Interesting, the App Store (iOS) did not alert of an available update; had to search for eufy security to discover. Available update alerts are (usually) automatic, if I’m not mistaken.

fwiw - the problem seemed to fix itself, sometime about a day after I opened a support ticket. (Still no response on the ticket, though.) I had already been on the latest app version on my phone - that was the first thing I tried. Though I did have an ipad that was on the previous app version.

Once I was able to log in to the app, I noticed in the system messages section that the doorbell software itself had updated on the morning of the 17th - so, right around the time I noticed I couldn’t log in to the app.

So either the latest doorbell software somehow confused things for a period of time, or having one device on an older app did, or it was a transient problem on Eufy’s side.

I did notice during the time when the app was logged in, but was getting “server unreachable” errors that the quick voice response feature was disabled, as well as the events viewer. Super irritating that nothing works without phoning home to Eufy, except the actual ringing of the bell.