Unable to add eufy HomeBase 2 - blinking blue

I Just recently bought the Floodlight Cam, Wired Doorbell, And the eufyCam 2C 2-cam Kit. I had an unreliable router/Wifi combo along with a Wifi extender and I was dropping Wifi constantly. Today I bought an Arris Surfboard and an eero mesh network and I have a very strong reliable connection now. The floodlight and doorbell hooked up to the new system fairly easily. However the Homebase 2 if giving me problems.

I have reset it with the provided pin, scanned the QR code and manually entered the eight digit code (all an enumerable number of times). I have deleted the app and reinstalled it (on two different phones). My phone is connected to the same Wifi as the HomeBase and it is connected to the router and powered by the provided Ethernet cable and power adapter. As of yesterday there were no new updates for it.

After powering the homebase 2 on, the LED changes from a blinking red to a solid red, then I get the welcome message and directed to follow the steps in the app, then a blue blinking LED. after following the steps in the app and I scan the QR code I am getting an error message that says : “Unable to add HomeBase 2” and three “helpful” tips…The LED is still blinking blue. rinse and repeat.

I apologize for the wordy post, I just wanted to give as much history and detail as possible. :zipper_mouth_face:


please send an email directly to: support@eufylife.com. You can get faster reply there.

Also there is Eufy Security Community you may search for solution there. Posting questions may not get immediate response. Just to let you know, due to an over-abundance of requests sent to customer service team in recent weeks, @AnkerSupport is unable to reply to your queries on the Eufy Security community at this time.

@Shenoy Thank you!

I tried to add the HomeBase 2 this morning and it worked first try. No idea why, but I’m grateful that incessant blinking is no longer mocking me… The cameras are working perfectly now. If anybody knows the solution to this or the reason it may help someone in the future.

manually entered the serial # and started the discovery process in the app and THEN held down the sync button once it was flashing and it picked right up. Took a few laps to do it. Auto-discovery didn’t work, QR scan didn’t work, manual add worked, but not as instructed

1 Like

Same issue here, multiple resets did not help. Does anyone know what the blue blinking light means? Maybe it is trying to get a new firmware?
The homebase is directly connected to my router and obviously got an IP.

Have you had any luck with this?

I’m having the same issue. I have the Homebase 2 plugged into my TP Link switch which is plugged into my Eero wireless router which is plugged into my Spectrum router. I’ve tried plugging it to the Eero directly and to the Spectrum router directly. Resetting the power each time just to make sure it’s picking up the IP. I’ve also scanned and manually entered the QR code. Still no luck. Not a good start and thinking I need to return this already…

Can confirm I had this exact same issue yesterday with my Homebase 2 which I managed to rectify in the UK.

My service/equipment:

  • BT Fibre 1000/150
  • TP-Link X60 Mesh Router plugged into an Openreach Huawei 1 Port Modem ONT
  • TP Link TL-SG108 8 Port Gigabit Desktop Switch.
  • Samsung M31 smartphone running Android 11 (for setup)

Legacy equipment I had which was used in this fix

  • BT Smart Hub 2 Modem Router (used only in Router Mode)

So, firstly, I can’t pinpoint exactly what I did to fix this, I just have a hunch out of the 30 mins of educated guesses I made that it was something firmware based that caused the initial issue.

So I started by plugging the Homebase 2 into my TP Link Network switch, and the lights went from solid Red to Flashing Blue and wouldn’t go solid Blue, which subsequently meant that every time I went through the process in the Eufy app of adding said base, I got as far as the scanning the QR Code on the bottom of the base/Manually keying in the code and then continued to receive an error message that wouldn’t allow me to progress to the next step of clicking the Sync button on the back of the base.

I tried different ports on the network switch, going straight into my TP Link Router, tried swapping out Ethernet cables and repeating the QR Code scan/Manual code entry and nothing worked, even if I was optimistically repeating the process multiple times frantically to no avail.

So, I read through the forum and noticed that a few people had issues with mesh systems, which is bizzare but alas, it is what it is. I’d seen a comment saying that it had been patched on a more recent firmware upgrade, so I thought I could try my old, ISP supplied BT Router and see if I could get that online, update the firmware and we should be in action.

I connected the BT Smart Hub 2 up, logged into the router’s interface and changed the SSID and Password to the exact same as my TP Link router in the hope that when I swapped back that it would auto recognise the same details and transition back over seemlessly without any additional setup being required.

Low and behold, when plugged directly into the BT Smart Hub 2 (not via the Network switch into the BT Smart Hub 2), the Homebase 2 passed the QR Code section, I managed to click the sync button and the first thing it prompted was to search for the most recent Firmware, which is at the time of writing the system version is and subsystem version is and this downloaded onto the Hub right away.

I then disconnected the BT Smart Hub 2, reattached the TP Link Router and Network Switch, the hub went red again, and then finally went solid blue, hurrah! Furthermore, I then managed to connect my 2K battery Doorbell up straight away to the system - blissful.

I don’t know if this issue is something to do with the Homebase acting as a wireless signal repeater and essentially the mesh system saying ‘You can’t join the party, your name’s not on the list’, so you’re not getting in’. Maybe? Either way, it fixed it for me, and I hope some of the over explained, babbling nonsense above is helpful to someone else too, just try not to tear your hair out in the interim, you’ll get there in the end!

1 Like

FIx!! i had the same problem. are you guys using android? i have the feeling is the android app but i can be wrong.
i tried with my old iphone 6 and worked in the first try.
i would suggest to turn off your phone data and make sure you do everything on wifi.
the sync buttom just need to push it when the app ask you to. if the app havent ask you for that yet means it hasnt find the homebase yet. so try a different phone .

It’s definitely something funny with HomeBase 2 app.

How I worked around.

  1. While flashing blue, use Apple Home to Add Accessory.
  2. Once added. LED goes solid blue.
  3. I then added a camera by holding the SYNC button on the camera, and once it beeped, I held the SYNC button on the HomeBase 2.
  4. The camera appeared in the Apple Home app.
  5. I opened the Eufy app. The HomeBase 2 yells out ‘The HomeBase has been added’.
  6. REFRESH your Eufy app by pulling down on the screen. The HomeBase 2 and camera will appear.



This one worked for me. Thanks. It seems that if you already have HomeKit operating, you have to go through that process first.

Thanks for the fantastic explanation!!. Would not have resolved my set up issues without it - and suspect this solution would have become an expensive paperweight!

Had similar experience when unboxing the Homebase 2 & Cameras for the first time. Had to unplug the ORBI mesh modem/router (is plugged directly into Fibre ONT and configured as the modem/router) network completely and change the router back to the basic modem/router provided by the Telco.

Reset the provider modem/router WIFI to the same SSID and Password as the Mesh Router; and turned off 5ghz (only works on 2.4ghz). Also needed to turn off all firewalls on the Provider modem/router. Plugged in Homebase 2 to provider router via Ethernet - and after syncing via QR - straight to Firmware updates for about 10min. Once updates; sync’d cameras via standard process using app on smartphone. Then unplugged provider Router; and reconnected ORBI mesh to Fibre ONT.

Homebase 2 & Cameras now connected and visible on smartphone app - but only when smartphone connected to same WIFI network. Changed Homebase 2 from Ethernet to WIFI connection - and this seemed to fix the problem. Took several hours for the whole solution to settle down (lagging / buggy on app and web interface) - but suspect that was due to cameras silently also downloading their firmware updates.

By the next day - system and cameras all stable and working as expected. Have to say - a very frustrating set up experience - and the live chat function is hopeless for tech support. Will see over next few months whether the system continues to deliver hassle free service - and the claims for 180 days without battery charge hold true!

This one worked for me. You need to add it manually and it will start working again… Thanks and good luck

What worked for me was plugging the homebase into a different Ethernet port!