SoundCore red light, behind the grill, will not go off?

I bought a SoundCore (A3102) last month and have used it 3 times. Now a red light is on behind the grill (over the faint ANKER logo/painted logo) and it refuses to go out. I’ve cycled it off/on quite a few times, played music through it a few more times, fully charged it until red light on the side (by charging port) goes out but the red light behind the grill still stays on.
Any ideas? Thanks in advance?

1 Like

I would recommend you reset the speaker. First, “forget” the speaker in Bluetooth settings from the device you usually pair it to. Then turn off Bluetooth on that device. Then, on the speaker, when in standby mode press/hold “BT” button for 2s.

You can then repair the speaker.

If this doesn’t work I would recommend contacting soundcore support at

Good luck!

Thanks; I tried it… a few times, but not helping. Still has the solid red LED behind the grill. Even when “on” it looks like the red LED is on at same time as the blue. Can barely see it but it’s there. Unit will still play fine, but I know this will wear battery out and if leave plugged in all the time, then that will be just as bad.
Guess I’ll try calling tomorrow.

I recommend you email them at the email I provided above :wink:

I had already did that with no response, then realized it was a holiday. Wasn’t thrilled about the light staying on for days so thought I’d try here for help. Thanks for trying!

1 Like

Thank you for your patience.
Our customer support team will reply you soon.

Is this problem solved?
I got same situation on my new soundcore.
Could someone share how to fix this problem?

My Anker SoundCore A3102011 Bluetooth Speaker is now frozen.Its not turning off.When i press the power button only the intro/starting tune is heard.No matter how many times i press the power button only the intro/starting tune is heard and the speaker is not connecting to any of devices.The status indicator is always on red.There is also a buzzing or humming sound coming from the speaker.Could someone share how to fix this issue