Soundcore Life Q10 works fine on bluetooth but left side is lower with aux cable?

Hello,

I love my headphones very much and I am more than satisfied with them. However, the aux cable given with them stopped working after 1,5 years. I bought a new Anker cable, but I realized that I am still having a similar problem. The headphone works well on Bluetooth but right side makes me very uncomfortable in comparison to the left side because of the inbalance between their sounds. Left side is much lower than it is supposed to be. Why is that and how can I solve this? I do not want to buy new headphones because Life Q10 is great but only when I connect it to bluetooth, which drains the battery faster. :frowning: The cable is new, the headphones work good on BT; so why does this problem occur when I use the aux cable?

Thanks :frowning:

What cable did you purchase? And make sure the cable is fully seated or plugged in all the way because that’s cause lower volume in one side.
Please also check and make sure that the headphone jack on your device isn’t the issue, try moving the cable around and see if there is any change in volume because if there is then your headphone jack is loose and needs to be repaired

Look for debris in the ports both ends. The left side is the one furthest in and where debris gets rammed in over time.

Don’t poke inside, put light and magnifying glass toward it first, on headphones and the other device. If you see anything then disconnect power, drain battery and use wood or plastic to pull out.

image

I’d try another aux cable

Thanks for your time everyone, turns out my computer somehow changes the volume balance when i plug in aux cable so both the cable and the headphones are ok… i fixed it so am writing the solution down incase somebody else has a similar problem.

sound settings > sound control panel > playback > right click on whatever device you’re intending to examine > properties > levels > balance.

mine was turned into L: 7 R: 24 for some reason and i did not know about this balance setting, so i believed it was the cable getting old until i tried a brand-new cable.

Have a nice day,

Thanks for the update and I’m glad you were able to find a solution