Soundcore Life P2 Left Side connected but no Sound

This worked perfectly!

Thank you!!

@AnkerOfficial @AnkerSupport i face the same problem. Left earbud turns on but no sound at all. I have tried this steps:

  1. Place the earbuds into the charging case and make sure they are being charged with a steady light on the earbuds.
  2. Press and hold the button on both earbuds for 3 seconds. The LED indicators will flash red 3 times and then turn white.

Still dont work. I have bought it through Amazon US. But now i’m in Brazil. Any thoughts on how could we fix it?

1 Like

Thank you for your message.

We are sorry for all the inconvenience this has caused.

If the troubleshooting doesn’t help, please reach out to the merchant who sold the item to you because we do not have any record of your purchase in our system. Since your purchase was made through the store Amazon US, they are responsible for fulfilling any warranty issues you might have, so please reach out to them to process a warranty claim. We wish you all the best with this!

For future purchases, please note our 18-month warranty covers purchases made through our Amazon store (such as AnkerDirect), our website (anker.com), or authorized resellers (such as Walmart). Here is the warranty details for your reference:https://www.anker.com/warranty

Again, we are sorry for all the inconveience.

I had the same issue. My iphone started recognizing each bud separately on bluetooth screen. One was listed as Soundcore Life Note and the other was Soundcore Life Note - L. Here is what I have found. On the Iphone forget each bud. Put the earbuds back in the their case and do I hard reset on both by holding buttons for a few seconds until they blink red 3 times. Take them out and sync your right bud with the iphone first, then turn on your left bud. Your left bud should not be listed on your phone’s bluetooth screen! If it does, select it to connect. It should pair and actually disappear from the selection window and start working. Again, you should only have one device listed on the bluetooth screen. Also if you have one bud with more sound than the other you can go into Settings>General>Accessibility and adjust right/left volume.

thanks m8 that did the trick for me

Hello I just received a pair based on a colleagues reccomendation. Brought them into office now I am only getting the right earphone and amusingly he is only getting the left on his set. Bluetooth/ device conflict. If they cant handle 2 sets in close proximity I am concerned.

Worked perfectly :+1:

Great answer. This definitely solved my problem and I was able to hear in both ear buds on my Soundcore life note.

I was able to hear only in one of the ear buds for some reason and when I tried to connect the other, the previous one would stop but now this is fixed.

Thank you very much for your help.

Thank you so much :smiley:

This worked for me, thank you!

Amazing! Worked for me as well ! :smiley:

Hi, This is Babin. Today I am talking about my Bluetooth Soundcore Life Note. I have bought it from Best Buy. My earbuds connect both but my left side does not listen properly. This is my first time it happens in few days.
What should I do?

Thank you
Yours Faithfully
Name: Babin Lama

This keeps happening to me too, i’m baffeled they haven’t fixed this issue yet, this issue is just software related as the earbuds were working just fine 12 hours before the left one plays sound super quietly. I’m on my third pair already and still the issue comes back after 2-3 weeks of light use.

Well if it’s happening on multiple buds it’s more likely something else you are doing wrong. Chances are you’ve paired with more than one device and so one bud is connected to something different.

There’s plenty of threads on reset.

sadly that didn’t help and i’ve only connected to my phone, i can still hear sound in the left earbud but only very quiet.

Well look for debris within the quiet bud, if it takes weeks then the earwax is the candidate.

This is what worked for me. I poked the left earbud speaker with a safety pin and it immediately regained sound.

3 Likes

This work for me too. I poked with safety pin in speaker holes softly and immediately sound regain. Cheers

1 Like

Poking the silver speaker with a safety pin also worked for me. Must’ve gotten dislodged or something.

I had the same issue and this worked for me. Don’t think this was in the documentation.

1 Like