Soundcore Liberty Air 2 right earbud not charging/connecting

It is good to share experiences so future searches find.

But if you want actual support from Anker, there is a dedicated Soundcore forum where Soundcore staff read.

No-one from Anker / Soundcore reads here (that we have noticed for year+ )

1 Like

Im having the same problem

My right earbud stopped working and couldn’t connect to my phone then I wiped the charging port with alcohol and it worked.

1 Like

I’m experiencing same trouble - afrer 6 months of perfect functioning right earpbud of my Soundcore Liberty Air 2 Pro stopped charging.
After cleaning/resetting etc. i got what issue is in charging box - and in my case reset of the box helps for a while - it charges both buds once. To reset box only (not the earbuds) you can put it on charge with charging cable.
Looks like a trouble with wake up from power save mode one of microcontrollers in charging box or its firmware issue.

I’ve been experiencing similar problems for months now - earbuds not charging and having troubles with BT connection. The problem seems to be entirely connected with a fact, that the pins that are supposed to charge the earbuds are hidden deep in their respective wells, making them prone to getting very dirty very quickly. Due to that, earbuds are not charging and the software disallows connection.

However, I think I found a solution - the pins inside need a very vigorous scrub using alcohol (I used 99% IPA) and a q-tip that you use to clean your ears. You have to put your heart into it and really try to scrub the dirt that is on the pins. After that, the buds connected without a problem. Hope this helps.

So im having the exact same problem and think i know the exact casue after plan A-Z.
If you look at the left charging base in the case, you see the order is pin, circle, pin. The circle in between the pins protrudes out a bit to make contact with the corresponding flat circle on the earbud.

I just noticed that on the right side, the circle isn’t protruding like the left, it’s actually flat, flush with the casing. Thus, I’m assuming, the pins make contact to tell the case a bud is has been inserted but the middle circle in between those pins is what charges since it’s magnetic. If that magnet cant connect to the bud then it isn’t making contact to even charge the right earbud.

The fact that everyone is having the same problem I’d check the case out. If it’s all the same EXACT problem as me, there needs to be a recall and replacements need to be given.

I noticed this issue after I dropped my case on concrete with the earbuds in them, and the right earbud wouldn’t work. I tried cleaning the connection pins and the right earbud would not respond to me holding the button on the case and wouldn’t flash red at all. I then tried dropping(only) the right earbud again, and now it works? :woman_shrugging: