Soundcore flare charging indicator

I just got my second soundcore flare. But with this one whenever I’m charging it there’s no light indicators going on at the bottom unlike the first one i had. Is this defective? Or anything else i can do to fix this?

Is it possible that it is already fully charged? Use it for a couple hours, then try it again and see if there is still no light. It’s also worth trying a different wall charger AND different charging cord just to rule them out. If the issue persists, please do not hesitate to reach out to Thanks!

I already tried different cords and wall charger’s. The way i found out that its not fully charged was with the application. Only the light with the power button is on whenever im trying to charge it.

I’ve double checked the FCC and no revision of that product is showing so new and old should behave same.

My best guess is there’s a button sequence to enable/disable the lights and as Ryan says email support to find more.

Try a reset may help.

Will do send an email, thank you. :blush:

And how do you do a reset?

1 Like

I don’t know but time me…

I’m not seeing a reset instruction particularly, I see there’s an app so absolutely once paired use app to check for firmware updates.

Seems you may be able to do the power press hold to reset?

I’d certainly try them all. It’s weekend soon so patient for email reply for say Monday or Tuesday.

It’s possible slightly (doesnt feel likely) it’s a dud so also gather serial number and proof of purchase if they deem it a fault.