RoboVac L70 no mopping! Help

I have a RoboVac L70, the mapping does not work (only dry). The water tank is full and the mop module is inserted.
what can i do, is it defective?

Mopping or mapping? Two different things I know (not an English speaker as well) . :smiley:
Think you mean mopping
You should give us more informations.

What kind of error indication do you get?
Normally (I got a 11S model) there are different “beeping” tones when an error shows up.

I believe the issue is the same as here below

Hi czesia.brodziak,
Here are few things you could try.

  1. Only use water, distilled is probably your best option. No cleaning solution. Not even vinegar, it would eat through that little spring in no time.
  2. Do you have hard water? Make sure that opening of the water plug on the tank is easy to push in or up. Use a pencil or straw to test, if its easy your good if hard get a tank replacement.
  3. Possible that mechanically press unit in Vacuum has debris or is broken. Inspect that part of the Vacuum make sure there are nothing blocking or is lodge in there. Or you need to send it for repair.
    Reach out to support for help. Community is not going to know much on mechanical part of this. Make a word document with bullet points, tried this, end result, tried that, end result. They will want pictures or videos too so be prepared.

Hi Alpkinoglu,
I have scenario for you. I know that you are not going to like it. But have you ever hear that saying about firmware updates. “You must factory default as the update added or remove features”. This applies to Anything wired/wireless; Routers, Modems, Phones, AV Systems, Consoles, Tablets, Bluetooth Speakers, TVs, Monitors (manually usb type), Docking station, Video Cards, Motherboards, list goes on and on.

Example: bluetooth speaker wont connect to my tablet, support and forums say there is firmware update that fixes that issue. You do some research and find the best approach. Apply the update via windows application with a usb to type c connection to that speaker, you disconnect usb cable and from what you read is telling you to hard reset/factory default; Volume down key and on/off button at the same time. You connect the tablet to the speaker and bam its working!
This is the day and age we live in. Firmware updates provides functionality or enhancements. Yes sometimes they break too but maybe the flash was bad. I wish I knew of way to help you through that process of re-flashing that firmware but I don’t. I only know the computer related ones.

Now, you don’t have to do this, this is only a suggestion. You may have to rely on support to help you make that decision. Read on!

Another possibility is what I told the gentlemen below about only using this type of water and no vinegar. Check the tank or unit for debris. Sure it could be coincidence that it happened when you applied the update but it could be debris too.

Final say,
Community is not going to know how to re-flash or downgrade, as this would be for an engineer. The best option is reach out to support. Make notes of all troubleshooting you did, tried this, end result, tried that, end result. Anything to have support dig in and give you the best option. They will want pictures or videos too so be prepared. I know its pain but welcome to the 21st Century!

I have the same issue all of a sudden after the device worked fine for exactly one year. I never added products and cleaned every time, just like the manual says.

I can’t tell if it’s related to a software update issue. Any way on figuring out if it’s related? The “water pump” makes a strange noise, as if trying to pump water from an empty tank. The tank is full however.

I asked eufy support and even sent a complete report with video. I didn’t get a solution, the only answer I got was that it seems defective. And just over a year no more warranty :disappointed::rage:

I am having the exact same issue with 0.11.32…I hear the noise like if it were trying to pump, the tank is full, but I got the insufficient water error.

Have you checked the pump, the pipelines?
May be there is a calcification.
I don’t have such a mopping Robovac so these are only some guessing

I couldn’t check because I don’t know how to disassemble it. Are you aware of some video or link explaining how to do so on this model? Thanks!

Youtube could help!

Have replied to similar topic but … looks like this is an old conversation without a result. If anyone had any luck with a fix I’d be keen to know.
Exact same problem for me (FW version 00.11.32) had not used device for quite a few months, so could be firmware update related (I did hear it tell me something about an update from it’s dock a while back) Have checked for blockages, etc and have only ever used just cold water.
Did anyone get a response from Eufy that was helpful?