Problems With Viewing Eufycams From A PC

Hi, I have 8 Eufycam 2c and 1 base. I like to view them through a browser on my PC. I am using Firefox. Typically when I go to the site and login in it brings up all the cams. Then I click play on one and I will get a notification to allow Flash. Then I allow and things are fine. But frequently I will either not get that, or after a while of having it open when I go to view a cam I will get "Failed to play.(20022). Sometimes I can close and reload the page and get past this, or clear cookies, but not always. like right now I am unable to view my cams. This is frustrating when I have over $800 of these cams and cannot properly use them. Does anyone else have the same issue? How did you fix it?Screenshot_2020-04-01%20eufy%20Security

1 Like

Thank you for letting us know your concern @24v. Please be assured we always stand behind our products and want to make this right for you.

According to our customer demand, we have made the LiveView available on the web channel, when you access:

If you still have the issue, please reach out to

Thanks again for your support! Have a nice day!

You have our promise that our engineers would work day and night to improve this product and we are glad to have your support and understanding, which would be a huge encouragement for us to seeking continuous improvement.

If you need further assistance, please don’t hesitate to contact us at any time.

Thanks again for your support! Have a nice day!

I am not sure what you did, but this did not fix anything for me. The ability to use this is very intermittent.
I also have trouble connecting from the android app. Sometimes it gets stuck loading, or I have to close and reopen individual cameras over and over to get it to work. I am very disappointed in this product at this point.

I also am on my second base as the first one kept getting the red ring of death. I purchased a second as a spare from Amazon when it was on sale with 2 cameras. I have tried updating firmware and have reset the base and had to re ad every camera one by one twice now. That really sucks as I have to literally go to every corner of my home on a ladder to bring the cameras down and back near the base.

Honestly at this point I am considering sending these back to Amazon and getting my money back. It is unfortunate because it is a sweet little system when it works.

Also, the first base kept getting the red light intermittently whether on ethernet or wifi. I know it is not a router issue as I have multiple other devices and none of them experience any loss. So I switched to the second base after resetting the first and trying everything I could. Now the second one will not make a wifi connection so I am forced to leave it near my router. It will connect to the wifi during the setup when the ethernet cable is connected, but then when i power it off, remove the ethernet cable, and power it back up it goes from flashing red to solid red and stays that way. Will not turn blue or connect to wifi.

This is incredibly frustrating. I can’t imagine I am the only person with these issues.

I am having more problems today. Nothing worse than getting a motion notification while you aren’t home and then not be able to view it. I have to literally open and close the app 3 or 4 times, then wait a long time and it finally loads. This is completely unacceptable for a product like this. I am returning these to Amazon and am going to try a different brand.

Thanks for getting back! @24v

So sorry to hear the issue still persists.

It is really unusual case for the eufycam series, please rest assured that we will fully take care of this case for you.

If you have purchased the device from eufyHome on Amazon, please email us your order ID to, we will be able to assist you with the return for you.

Apologies again for any inconvenience caused. Looking forward to your reply.

I also experience an "Failed to play.(20022) "error. Can you help me with that?

Thats fast. Thank you

I also have that problem. Failed to play.(20022) "error.
What to do?

I was also getting the Failed to play.(20022) "error.
I turned off adblocker just for the live camera page which reloaded it and everything was normal again.
After my camera loaded and live video was showing, I simply turned adblocker back on and all was well again, even when stopping and playing live video several times.
Hope this helps someone…

April 2021, still the same problem with both of my cameras. Using the latest version of Chrome/Edge and Windows 10 - very frustrating. I get this message at least 30% of the time. Android app on the other hand almost (not always) always works. Please fix this.

May 25, 2021. I also have this problem since 3 weeks. Tried to change routers in network, diffrent computers and another homebase without any result. android works in all routers’ networks. Using Edge and Firefox in Win 7 and Win 10… Have no preblems with any other equipment in home. What to do ?

I’ve purchased 4 of the Eufy pan/tilt cameras and was impressed with the ease of setup and installation. I do however have a problem with one camera which gives me the 20022 error when accessed from Windows 10 using either Edge or Chrome. The camera works just fine when accessed from my Android smartphone. Is there a fix for this yet?

The first item of business is what is the camera that is having this issue. I know the new s40 was having this issue and I am thinking they were working on that. If it is not that, you will need to tell us the camera’s name.

Email support, that can look into it

They are all P24 cameras and like others who have this problem, there is no pattern to when the error occurs. Sometimes, I can access all 4 cameras but the next time I try, 1 or more will either give the 20022 error or just sit there spinning.

I just bought mine and I was having this problem, you need to update the firmware.

I also encounter the same issue, when I open “” for streaming I get the error in the picture Ekran%20Al%C4%B1nt%C4%B1s%C4%B1

You need to resolve this porblem.

Same problem here, was working for a few moments. But actually same failure.
Firmware of Homebase2 is and the eufyCam 2 Pro have all 4.1.4 and Subsystem 1.0.98-20210826.

The App is working fine in local WLAN and 5G external.

Same problem 20022.

Eufy. Is there a fix for this ??? We