No power on. not working at all

I’ve just tried to update the firmware for my Anker Soundcore Flare and now have the same problem - no power, not working. Very disappointing.

Hi @carol17 I would suggest you log a support ticket with Soundcore using with your issue and troubleshooting steps taken so far.

Thanks for the advice ndalby. While still connected via USB cable to my PC I did finally manage to resuscitate the Flare by repeatedly pressing various buttons (sorry I can’t remember which) until lights came on. I followed this swiftly with a factory reset (power and volume buttons simultaneously). I put the Soundcore app on my iPhone and then used that to install the latest firmware on to the Flare – very straight forward. On Friday I contacted Coda Computers asking for the latest Bluetooth adaptor, they sent the link for the driver package yesterday (Monday). So today finally the W10 laptop is connected to the speaker.

I’m having the exact same issue ! I’m so angry ive used it twice … any chance you got yours working ? Please let me know thanksS

The following worked for me, seemed to be an issue with the switch position.

Slide Power Button All the Way to the ‘On’ Position, then Lightly Tap it Back.

The power switch can become misaligned, allowing the switch to move past the point of connecting the current to being ‘On’. If your unit will not power up, or does so intermittently, try switching the power from ‘Off’ to ‘On’ past the audible and tactile click / bump resistance, then lightly thumb the switch back (towards the ‘Off’ position) but only until you meet faint resistance. Wait a few moments to see if this powers the unit up.

My rave party cast speak will not power on anymore. Does anyone know how to fix this.