Nebula Capsule II stuck in boot loop

Anyone with Capsule 2 ever experience that the boot loader is stuck, showing only “Nebula” and restarting on its own?

Since there are no instructions to factory reset this projector in the instructions, I would reccomend contacting nebula at

They have a great support team, and would be glad to help you! They are off on Saturday’s, so you won’t get a response until Monday or Tuesday.

Good luck!

Its too bad for a new product. I heard great things about Nebula Capsule I but II has many complaints so far on our forum.

1 Like

I am dealing with the same exact issue. It won’t go past the Nebula logo, and it restarts itself when I try powering it off. I tried holding down Power and Volume+, the first step in the factory reset process I’ve found, but it doesn’t display the android logo. After waiting a while, a dead android logo guy has just appeared with a red triangle over him with an exclamation mark in it, and below him, it says “No command”. Is this the equivalent of a PC blue screen of death?

I started experiencing this when I plugged my Roku streaming stick in for the first time. The Capsule will not get past the boot screen with the ‘NEBULA’ logo.

If I unplug the Roku stick the unit boots up fine, and I just have to reconnect the stick after the main menu has loaded.

Not ideal, but maybe worth checking whether it is your Roku or other device interfering.

1 Like

i´m having this issue right now. does anyone got a solution?

1 Like

Any fix for this?? Experiencing this first time last night

Did you find a solution on how to get out of the Android recovery loop?

My Max is only 14 months old and it will not even turn on light see even the android wipe menu. It is stuck in an infinite blue light for 5 seconds then one red light flash, repeat, repeat… Support told me to buy another another at discount (basically meaning f-off). I will join any class action law suit anyone one wants to start to sue these a-holes. This $700 capsule Max is a piece of a crap. We have to sue this company for selling defective junk.

Nope, support says the Supervision was looking to get an answer from engineering (been 2 weeks with no reply). I keep phoning every week and still get no answer. Amazon’s 1 star reviews just disappoints me more since a lot of seem not boot up after awhile.

I’m confused. Why are you looking to sue a company for adhering to their 12 month warranty? They are even offering a discount on a different device.

I’ve had multiple android devices fail after a year; none of those manufacturers gave me a discount or even bothered to respond to any support communication. It stinks that it failed, but it doesn’t mean that it is defective.

The product is defective and unserviceable on purpose. So you want me to buy the same defective product ($700) at a discount. Check the reviews on Amazon, it malfunctions. Do you work for Nebula or just a troll.

Here is Ankers / Nebula reply: Sorry for keeping you waiting. My name is Ryan, and I am the Customer Service Manager at Anker. I’ll follow up on your case.
After consulting with our R&D team and reviewing the video you provided, we have determined that the issue is hardware-related and cannot be resolved through software. We suggest trying to reset the device by holding down the power button for 10 seconds to see if this makes any difference.

As the product is now out of warranty, we are unable to arrange a replacement. However, we would like to offer you a 20% discount on a new order. Please note that this discount cannot be combined with any other promotions. To take advantage of this offer, simply make another order and email me the new order number. Once the order has gone through, I can issue 20% back in the same way your order was put in.

We understand your frustration and genuinely hope you will consider giving Anker products another shot. You are important to us, and if you have any questions about our products or other concerns, we are happy to help.

Best regards,

Reference TicketTND86412825 if contacting a CSR
Nebula Customer Support Manager
---- my reply ------------------------
After consulting with my better judgement, I have determined that this piece of crap (MAX capsule) you sold me 1 YEAR and 2 WEEKS ago is now a $700 paper weight.
I will until the day I die (I’m 65 now) post on every website and forum, why the projector is a defective product that cannot be serviced or fixed once it self-destructs 2 weeks after warranty.
I will encourage anyone who buys this defective projector to join into a class action suit.

Robert Stewart
A totally ripped off client of the Nebula Max projector.

Neither. Best of luck to you.

I also facing the same behaviors.
It must try to more or times to reboot the my Nebula capsule till it into the Android system.
Into the Android system also has hung up issue more frequency then kept reboot then in to the nightmare loop.
Reset Factory setting also cannot get the improve.
I would like try manual to flash firmware.But no firmware could be found and try.
That is very so bad experience.
Looks no any solution yet according above discuss.

Google TV is also shown same issue.
Insert the stick good is after android system fully boot up.
But you should so lucky.Still can boot up your device.:face_with_hand_over_mouth:
I also suspect there has a bug when insert within a HDMI port for start up the device