My Anker speaker’s power light stays solid red

I just got my anker speaker yesterday and played music on it a few times that day.Then, out of no where, the power button turned red and I couldn’t do nothing on the speaker. It can’t even connect to Bluetooth, play music, and I don’t know whether this light means it’s on or off! Someone please reply because I just got this and it’s already not working


Hi @Brian114
Few things that might help, but was it fully charged when your started using it?
To soft reset a SoundCore speaker you can hold the power button down for 4 seconds.
A hard reset can be achieved by pressing the power button and bass up button for a few seconds.
Also, try putting it on charge for a few hours and see if additional charge breaks it out of it current state.
You can contact for help.

Let me know how you get on.

I’m not sure if it was fully charged before but I let it sit on the charger for a couple of hours and it’s still red.

1 Like

Hmmm, tried the reset options?
If that doesn’t work drop a message to the support email address and see if they can offer any further help.

1 Like

Yes , I have tried resetting and it is not do able

1 Like

You might contact the support as @paulstevenewing mentioned.
There should be help.

1 Like

Hey bud I had the same exact problem and I got it fixed by doing the hard reset. I pushed the power button first, then I pushed the bass and + button at the same time and held it in for a few seconds. Hopefully you already got it fixed and if hopefully this helps you

1 Like

I have this exact problem, anyone fixed theirs? Please help!

Did not work for me :confused:

Hi, have you fixed yours?

1 Like

Hi @Dan_Gogh
I’ve not had any issues with mine mate.
Yours still presenting the same issue?

My Anker SoundCore A3102011 Bluetooth Speaker also have the same exact problem.The status indicator is always on red.On pressing down the power button only the intro/starting tune is heard.And i have tired everything,its still not working.Plz someone share a solution for this issue.

Please ask the ANKER/soundcore support.
We are definitely NOT the support here.
Sorry to mention that.