Mars II Won't Power On

My Mars II won’t turn on. It shows four power LEDs, so presumably it’s fully charged, but nothing happens when I open the shutter (either with or without the AC cable connected). Are there any troubleshooting options for a “dead” projector?

1 Like

Long press the power button and see what happens. And also try this:
Slide up the lens cover and wait for 10 seconds, then try again

1 Like

Although I do not have one, I believe some additional info may be needed. How old is it? Has it been connected for long period of time?. Was there an issue during previous use?. (overheating, randomly turning off or lighting issue Did you unplug it for a bit? or unplug before it cooled down?. May want to check if there was a reset button.

I have had this issue and its because of the power plug. Please unplug the power plug and press the reset button on the back of the unit. Then slide open the shutter and it should turn back on.

The issue that myself and others on reddit have come to the conclusion is that the powerplug develops an internal grounding problem which prevents the Mars II from turning on. As long as the plug isnt plugged into the back of the projector it should work, if you need to charge it you can still use that plug but the projector has to be off.
But at this point it would be time for a replacement power plug which is available on Amazon


What should I search for on Amazon in regard to the charger?

Here you Go

(Sigh). Finally went ahead and ordered a replacement AC adapter, and it worked immediately to charge up the Mars battery (according to the status LEDs). But the projector still won’t turn on. I’ve tried holding down the reset button for several seconds, both with the shutter cover open and closed, with the AC adapter connected and not. Is there a special reset technique I’m missing?

It might sound funny and ridiculous - but I have had two Mars II projectors so far and had to return one because of the very same issue. I figured out that if you warm the projector up before turning it on, it will work. Just give it a go and let me know because I want to know if the problem persists so that I can return this second one in time as well. But so far, it works for me…

(Sigh). I’m way out of warranty. How do you “warm up” the projector when it won’t start up - just leave the shutter open for ~10m then try closing/opening it? Tried sending an email to support, but that’s been ignored for almost a week now. :face_with_raised_eyebrow:

No, no - just put it on the radiator or direct a heater fan at it with the lid closed. Then give it a go… :slight_smile:

I hat this happen to me once, same description - charged, wouldn’t turn on when opening the lid. Tried several times. Then I tried turning it on with the remote… and it worked. I hope it can be as simple as that for you.

Mine doesn’t come on when the lid is down. sometimes it comes on if you keep the lid down for a long time (maybe 20 mins) but then it powers off by itself after one mnute, then gets into a repeated reboot and power down cycle.

I sent an email to Anker support but no response yet.

As I mentioned, mine was fixed by just warming it up before turning it on using a radiator or a fan heater. Now, I keep it in a warmer place and after using it everyday or so, it has become a lot better.

(Sigh). Just now getting back to this.

Plenty warm here most of the time here in SoCal, so I don’t think “preheating” it will help - leaving the shutter open and trying the remote don’t seem to work either. I’d tried emailing Anker support (twice) and never got any response

I’ve always received very good support from Anker for their external batteries and charging cables. Grrr.

Over the weekend Anker support responded to me, and are offering a swap for a refurbished unit at a discounted price. I’m interested, but they want me to “pay us… via the PayPal account for the new order” which seems a little weird. Anyone else been asked to make payments to Anker via PayPal?

Seriously - Anker now wants me to send a PayPal for the exchange to an (not address, and I have to send both payment and my unit first - can anyone confirm this is legit? :no_mouth:

Same here.

have this thread. many others seem to have the same issue.

My advice, is don’t do it. Not because I think it’s a scam, necessarily, but because a new projector isn’t likely to fix the problem. I’m on my second dead Mars 2 projector. Both have had the same problem. The first one worked for a long time (close to a year) with some intermittent random powering off issues, but being mostly reliable. (The times it did have trouble were mainly that it would just randomly shut itself off in the middle of a movie or something even if it was plugged in or had plenty of battery life left.) Then, one day it just refused to power on at all. Like others, the battery status lights indicated a full charge. But when I opened the shutter, either nothing happened, or the projector fan would start and the bulb might come on briefly before everything shut off. It would repeat this start up/shut off procedure a few times and then just stop trying to turn on. It did this regardless of whether it was plugged in or not. I contacted Anker and they told me that they would send me a replacement, but that since it was outside the one year warranty (barely), the new replacement projector would not be warrantied. Well, I received projector number two and guess what…same exact problem. I’ve tried everything I can think of. Most of the time, my projector stays mounted, so it hasn’t been damaged by dropping or anything like that. I suspect that the problem is cheap wiring in the shutter or something so that the projector doesn’t get the “shutter open/power on” signal. It’s not the charging cable, because unplugging and resetting the projector as Tank suggested didn’t fix it. I’ve tried emailing and calling Anker and have not received any real reply. I called them yesterday in the middle of the day and they still haven’t returned my call. Either they’re dodging my call, or they’re so swamped with customer service calls that they are HOURS or DAYS behind in returning calls. Either way, not a company that is going to get any more of my money. Shame on you Anker.


We are experiencing exactly the same problem. Worked for a little more than a year, and now is turning on/off by itself and eventually off. So annoying. We bought it in august 2019. Any advice about how to reach Anker? We live in Copenhagen shoot them an email