Liberty Neo - left earphone won't work

Exactly the same model & same issue I am having. Did all the steps suggested in the thread & still left ear only blinks 4 times when in case and then nothing. The left earbud is the only one that flashes pink when I do the 8 second hold. And before anyone asks, YES they have both been fully charged.

1 Like

What if you hold the button and the red light DOES work on the other earbud? My right earbud keeps going out and I’ve only had these for approximately 24 hours… They’re fully charged and I tried resetting more than once. So I just tried what you advised but the red light illuminated on both earbuds, yet the right one doesn’t work. It was working fine earlier.

I just spent three hours trying to get both headphones to work TOGETHER!!! Thanks for this info! It worked the first time I tried it.

Worked for me, thanks!

For me, I simply just put both ear buds back into the case and then take them out (but make sure your phone’s bluetooth is on and already paired)

This instruction worked for me. Model A3911011

My left earbud do not have any light at all when take out from the charger. And I have tried to push and hold short and long the button but nothing happened, no light at all. Any suggestion on what the problem is? And how to resolve?

This worked for me finally :star_struck::star_struck: the problem was that for the 8 second press I was taking them back out of the case instead of pressing the button for 8 seconds till it turned pink while there were still in the case!

Try it hopefully it’ll work for you all too :slight_smile:

This got it for me! Keeping plugs in case during second restart rather than 8 seconds outside case. Model A3911 (A3911L A3911R).

First hold buttons five seconds outside of cradle to turn them off. Next forget connection(s) in bluetooth setting on the phone. Then put them in the cradle and hold the buttons 8 seconds until red light flashes 3 times (no pink). After pull them out and watch for right to flash white fast and left slow. Now go back and find a new on bluetooth setting and connect. You should have just successfully reset and re connected your buds. Enjoy!

1 Like

I tried all the solutions listed above and in the manual and nothing worked UNTIL:

  1. Leave the earbuds in the charger
  2. Removed Liberty Neo from Bluetooth list (Forget in Android)
  3. Turn Bluetooth off on phone
  4. With the earbuds in the charger hold the button on the right earbud until the red (pink) light flashes 3x and release
  5. With the earbuds still in the charger hold the button on the left earbud until the red (pink) light flashes 3x
  6. Remove both from the charger – let the earbud settle until the right one flashes quickly and left slowly
  7. Turn on Bluetooth on phone
  8. Try pairing a new device - Soundcore Liberty Neo

At least for me, this solved it, finally.

Update: It seems to have only worked the one time. :frowning:

I had Soundcore Liberty Neo for 18 months now. Worked perfectly fine until yesterday.
Suddenly could not connect and resetting/pairing did not work.
Tried all your suggestions, different options, spent more than 30 mins trying to fix it
Pairing does not work anymore and gives me an error message : “couldn’t connect”.

Very disappointing, I liked Anker brand and told many people about it.
Well, I cannot recommend it anymore, and will not buy another Anker headphones anymore.
Time to move on to a more reliable brand.

This is how I stumbled on the resolution for this problem:

  1. Turn the earbuds off.
  2. Place both earbuds in the cradle.
  3. Hold both buttons down at the same time until the earbuds light up.
    They should work. the problem is that earbuds are not syncing. You have to get them to sync.

I learned this after buying 3 pair :frowning:


Place the unsynced headphones in the case and hold both multifunction buttons for a few moments until the lights flash red. Boom, that worked for me.

Yay! It works! I’ve spent 30mins to fix my 2019 refreshed version of the Liberty Neo. Thank you so much!!

I took my left one out the case and it doesn’t even say that it can be connected to, I don’t know what to do.

Unfortunately, despite the numerous times I’ve tried, this didn’t work for me.

1 Like

Model A3906. None of the solutions mentioned above worked for me. The left headphone works to control music and power down the pair, but no sound.

glad it worked for you…not for me. With both in case, the white light is lit and no amount of holding does anything.

No matter how many times I try, this just doesn’t work