Liberty Air 2 microphone doesn't work with recording & voice memo apps

I have a newly unboxed pair of Liberty Air 2 wireless earbuds. I am really enjoying them so far with one exception. I have been unable to use my voice recording app with the earbud mics (I have a pixel 3a). Earbud mics work with phone calls.

Has anyone figured out a solution to this issue? Are there some bluetooth/phone settings I need to activate in order to enable recordings?

1 Like

Hey @Karen_Wu
I would think this is a phone thing, giving the microphone on the phone priority.
@Shenoy has a Pixel 3 but not sure of you have any Bluetooth buds? Does yours function the same Shenoy?

1 Like

@paulstevenewing i have Liberty 2 Pro, Spirit Dot 2 and Spirit X2… Only paired Liberty Pro 2 with Pixel, works fine for music…not tested the recording app.

Will give it a try and post the result here

1 Like

Nice one @Shenoy
Hope you didn’t mind me dropping your name! :grimacing:

1 Like

No, like to keep testing :blush: always something new to explore

1 Like

We are sorry to hear your headphones are not working properly. According to the information you described, the issue you are experiencing is very unusual. Thank you for trying some torubleshooting already, it seems that the issue was unusual.

Be assured that we always stand behind our products, providing an 18-month warranty that covers any quality or manufacturing related issue. Please don’t hesitate to contact us at by detailing your order number and the problem you come across. We will reply you within 24 hours.

Hi, has there been any resolution to this? I am currently facing the same issue with my OnePlus 3. I have tried unpairing and forgetting the device and re-pairing but it doesn’t solve the issue.

The microphone works okay in phone calls but I want to use them for voice memo as well.

Hi, just adding fuel to the fire here. I also have a pair of Liberty Air 2 (which I am loving in all regards except for the one mentioned here) and I have had no luck using them with voice memos. I’ve tried about 5 or 6 different memo apps that claim they work with bluetooth headsets, and I cannot get my voice to be captured by my earbuds. I have a Motorola Moto e6.

Turn off contact sharing sometimes works.

Change from


Has anyone found a resolution to this issue? It’s been 6 months since and I’ve been keeping my liberty air 2 software up to date. However it’s clear that the recording apps are picking up sound from the native phone mic rather than the liberty air 2 mic. For example when I have my phone in my pocket, the voice recording still picks up but is muffled.

I haven’t checked if this affects call quality, but will test and report back.


I just got Anker Soundcore Life P2 Mini and I’m having the same exact problem. The mic only works in calls. But otherwise uses the phone’s mic. My phone is a Huawei P20 Lite. Could it be that the mic only works with certain softwares or smth?? I don’t get this.