Can’t connect to eufy HomeBase when not on home wifi

When I’m at home, on wifi, my eufyCam system works fine — no issues here.

When I’m out of my house though (or even if I just turn wifi off on my phone while I’m at home), I can’t play live feeds from my eufyCams, play or delete any recordings from the HomeBase, or update any settings — in all cases, the little loading icon spins for about 10 seconds and then eventually times out.

See video here:

If I retry this 10 times, maybe 1 of these will eventually connect and play — but this isn’t really feasible when my HomeBase alarm is going off and I need to see who’s at my front door!

I have this issue on multiple devices, and some of these are brand new iPhone 11 Pro’s (everything has the latest iOS updates installed). Likewise, my eufycams and HomeBase all have the latest firmware updates too.

I can also confirm that my 4G network is providing good speeds of +100mbs, so this shouldn’t be an issue.

I just returned and replaced my entire eufycam system last weekend, and did a compete wipe and reinstall of the eufySecurity app, but am getting the same issues on this new one too — so the only constant here is the eufy software/firmware, however support have no idea what to do.

Any thoughts?

Sounds like a fault under your EufySecurity account. Have you tried emailing with the issue you are having and any troubleshooting steps you may have completed?

Have you resetting it?

Yep, I’ve been in contact with support a lot so have tried all the basic troubleshooting steps like reinstalling the eufySecurity app, resetting the HomeBase, plus resetting my iOS network settings — and when none of this helped, they told me to just return the whole system.

I’ve also submitted my eufySecurity app logs which they’ve apparently sent to their engineers for analysis, but I haven’t heard anything back.

Did you get any resolution? I have the same issue!

Hello, same for me, since several years now.
The access to the homebase works randomly. Most of the time, i get the mesage : “can not access to homebase (-3)”.
I am wondering if this could not come from my installation as the Homebase 2 is connected to a 4G+ LTE Huawei routeur (operated with a SIM card).

I have bough and installed the same material (with EufyCam 2 pro) to my neighbors and they have exactly the same issue. It’s quite disappointing.

Any ideas ?

But not sure if the answer will be satisfying.

Thanks for the tip.