C200 webcam firmware update fails

Using AnkerWork on my Windows PC, the firmware update from 7.2 to 7.5 on my new C200 webcam fails with “Update error” and suggests retrying, which also fails. Anybody else encounter this and solved it?

I just got mine, and I have the same issue. from 7.2 to 7.5

“Update error. Please update firmware again or disconnect the device, and then install the firmware again.”

1- I tried with the privacy cover open and closed. Same behaviour.
2- Did a Restore factory settings, and … Still the same behaviour.
3- I clicked on the C200 in Bluetooth and other devices… then Remove Device button
4- … then I unplugged the camera … and plugged it back in.
5- … while Windows was trying to setup the device I initiated the firmware update :slight_smile: … and it worked.

I was about to reach to reach out to support before step 5
support@ankerwork.com (in case it’s needed)

Now I have 7.5 installed.

What version of Windows are you running?

Windows 10

I really can´t update the firmware. Tried your suggestion several times. Did someone else face the same issue?

Funny, now when I open AnkerWork and check for firmware updates, it says the installed v7.2 is the latest version???