Anker SoundBuds Slim Audio-Video delay

You are not alone. I have the exact same situation. I can listen to music on my OnePlus 5T but when I want to watch something I would normally use my iPad.

The problem is that I have an audio video delay by over 3 seconds.
I have owned many soundcore earphones because I lost the others but the new slim are the worst you could get.

I assume, Anker messed something up with apple.

I have the a pair of these (as most of the members here know by now :joy:) as well but they have been working fine ever since I bought them apart from battery issue in the very beginning. I also have a iPhone 7 and have used Netflix to watch shows without that issue. Glad you got the issue fixed though

Glad it’s working, if it happens again just reset everything u till next time

1 Like

We are sorry to hear your headphones are not working properly. According to the information you described, the issue you are experiencing is very unusual. Please try the following steps to see if it helps at all.

  • Please use the headphones to listen to the downloaded music or video of the phone to see whether the issue still persists.

-Try deleting the pairing history on your device, resetting your device, then try to pair with the Anker headphone again

-Try pairing the Anker headphone with another Bluetooth device.

If the issue still persists, don’t worry, please don’t hesitate to contact us at support@anker.com by detailing your order number and the problem you come across. We will reply you within 24 hours.

2 Likes

@AnkerSupport / Anker Team… Thanks for posting Troubleshooting steps :thumbsup:

1 Like

So I’m having this same issue, I noticed specifically watching YouTube videos off my MacBook.
Odd thing is that the audio through the headphones is AHEAD of the video by about 1-2 seconds. Consistently.

I tried deleting the Bluetooth profile for the headphones yesterday and re-paired. AUdio and video were then aligned…Hooray!

Tried again today and the problem is back. Deleted the Bluetooth profile again, re-paired, but the delay is still there. So as a “workaround” this seems to be inconsistent.

I am also have this exact same issue. Noticed first with YouTube videos where the audio through the Anker SoundBuds Slim (Bluetooth) is 1-2 seconds ahead of the video. Tested on iMac.

I was able to sync once by disconnecting then reconnecting, then a full refresh of the page… but the sync reappears and the same issue with audio being 1-2 seconds ahead of the video appears with the next video.

I disconnected from the iMac and connected to an iPhone, and it did appear the audio + video was much closer to being in sync. I then reconnected to iMac and we’re back to the same 1-2 seconds audio ahead of video problem.

I gave the SoundBuds to another person to test on their computer (Macbook Air) and a few minutes later they returned and said there was something strange happening. The audio was ahead of the video by a few seconds. The exact same problem.

Do a youtube search for bluetooth audio delay on iPhones and Macs, you will see its not just anker earbuds but a lot of other bluetooth devices as well. Sometimes the issue even appears on android phones and tablets, but its mostly an issue with iOS

@Tank – The audio is not delayed. The audio is ahead of the video by 1-2 seconds. The video becomes delayed.

@tnamouz @AnkerSupport I’m running into the same issue on my android phone. The video lagging behind the audio also becomes more pronounced the longer the playback time.

@AnkerSupport I am facing the same issue with Anker Soundbuds Slim and OnePlus 7. Audio is ahead of video by 2-3 seconds. Also, the video doesn’t play that smoothly with Anker earphones connected. I tested
the same phone with 2 more bluetooth earphones Boat Rockerz and Sony WC300, they are working fine. Surely, this is an Anker only issue.

@tnamouz @AnkerSupport I am experiencing the same issue as the posters above. I received my SoundBuds yesterday and they work flawlessly on my phone (Samsung s9) for music, gaming and video. I tried them today with my MacBook Pro and noticed that the sound was about 2 seconds ahead of the video playback in Youtube. I tried deleting the Bluetooth profile, resetting the headphones and refreshing the page a number of times but I continue to have the sync issue. The work-arounds listed above have not worked for me. I have other Bluetooth headsets that have worked fine with my MacBook. Is there a fix for this issue yet or should I reach out for a replacement pair?

Thanks All!

UPDATE: I just played some PUBG Mobile again and did notice the audio and video was slightly off sync but I know this is probably more of an issue with running bluetooth headphones in general.

I got my Anker Slim + yesterday and have found the same problem. The video lags behind the audio by a few seconds. The lag happens when I use my macbook pro on several websites. However, there is no lag between audio and video when I use my phone ( Moto G4). I have tried deleting the bluetooth profile from my macbook as some of you suggested but it did not fix the problem.

I’m having the same issue (audio 2-3 seconds BEFORE video) but with the anker soundbuds curve, not the slim. Has anyone found a fix yet?

@AnkerSupport I also am not able to reset the Soundbuds slim + by pressing both volume up and down at the same time…

same issue here. super annoying…

@AnkerSupport same issue here. Any workaround for audio 1-2 secondsahead of video. I have tried the steps listed thus-far.

Same issue here. I’ve had the original Soundbuds Slim for 18 months and never had this issue. Just treated myself to the Soundbuds Slim + for the increased battery life but they are unusable because of this delay.

I open Netflix or whatever, press play, The audio starts whilst the video stays frozen, and then the video starts but theres a 2-3 second delay between the audio playing and the video starting which continues throughout. Same issue on both my iphone 7 and ipad mini. Netflix, Prime video, Youtube all behave the same.

I should have stuck with my old pair… seriously unimpressed.

Exactly the same issue with my soundbud slims. Tested on galaxy tab s3, note 8, iPhone X and iPad mini. Very odd. Video on Netflix/Plex/YouTube stutters for a few seconds as soon as you start playing and then audio comes before what’s happening on screen.

Disappointed Anker hasn’t replied to this thread, have been an advocate of their stuff for years.

Mainly use them for podcasts, which is why I didn’t realise for weeks this was an issue.