Anker PowerExpand Elite 13-in-1 Thunderbolt 3 Docking Station / HDMI Problems

We’re agreeing (I think).

I’m saying the issues arise “first cause” with a bad hardware design manifesting as a software cause and Anker gets blamed.

The only failure which can be legitimately put to Anker is the vast numbers of hub types they make, it makes each hub less important, therefore less tested therefore fails earlier. I’d expect Windows and Mac to share failures from the many hubs cause.

The notion Mac is blameless and it’s Ankers fault is wrong, I’d say 60% Apple fault, 20% consumer fault, 20% Anker fault (debatable).

I’ve had corporate laptops for 25 years and if I needed more ports got it with the official docking station. That at least is most likely to be tested by the laptop maker as it’s their own hardware. The notion you have a USBC port and hub and devices work is where the consumer shares in the fault. I’m amazed it works at all.


Old laptops old devices -> All works fine with Linux.
But who cares about Linux only some weirdos as we do.
And I am the most Neanderthalian as usual. :joy:

Linux did not penetrate corporate desktops. It only really got popular as a Unix and Windows NT / Server replacement.

Linux users to the most degree are technically more sophisticated, individuals, and that fights the corporate SOE “standard operating environment” intention. With Linux effectively banned it is common for the more technical to prefer Mac as it’s the next best thing to Linux. So I’m not surprised when I hear corporate and Mac and engineering in same context.

But that’s orthogonal, few-ports laptops for the problems intended, cause a hub and causes a layer of complexity which is the root problem.

I can request a hub from my company, that IT suggests, but it’s uglier than this one. I was hoping to have a nicer cleaner looking piece of hardware on my desk than the one supplied by them. But I guess that will not be the case.

I just find it interesting that it works fine on all machines but Mac, and I don’t think it’s mostly Apple’s fault. I think the companies that claim their hardware works on a MacBook Pro, that’s common in engineering, and solves a multi-display problem… it should do that, and it does not.

I think it’s completely reasonable for something like this to be expected to just work. ¯_(ツ)_/¯

Thanks everyone. I came here in hopes I was missing some small trick, or to get some real support. Ah well. I don’t know why I thought that would happen. Have a great day being condescending folks.

If your are working at an university (informatics) you see that there are many LINUX-users, of course
We loved it,. Not so boring as Mac:Os and MS.
More to work, more insight, open source.
So many more chances to playi around with.

Companies will not use.
They are slaves of MS and Apple.
Often nobody is there (admin) who got knowledge and cares about soft-and hardware.
And if so, for those admins its easier to take some expensive solution they got pampered in.

Of course the servers use LINUX, but the millions of MS users dont care and know,

Sorry, that was not our intention at all.

1 Like

Look through corporate eyes. There are no top level bundled laptop with OS with support other than Mac or Windows (Dell, Lenovo, etc) so that’s your two choices unfortunately. I’d not say it’s the corps fault, well not individually.

I don’t think this is a Mac Vs Linux Vs Windows issue at all. No matter what OS you used a hub adds a layer of complexity which is inevitably going to cause issues. The surprise is it works for some of the time.

Microsoft tries to solve this via device drivers, they test, but we still see here just as many, if not more Windows 10 issues, don’t we?

To claim this is a fault of Anker in where the condescending begins.

I never will count WIN issues.
They fix their bugs by creating new ones. (sarcasm)

But lets stop that discussion!

Hi All,

So I did some digging. Per this video –

There seems to be a Mac issue with HDMI and superultrawide monitors.In the notes, he links to a usb-c to display port cable. I plugged that into the thunderbolt port on my power expand and it is working beautifully. (Plus, I’m getting HDR when connected to windows, which I wasn’t when using an hdmi cable.)

Hope this helps or at least points you in the right direction.

Great share, thanks for helping out others with this beastly docking station.

Wanted to come back here and share what my final resolution was. I will say that the Anker Support folks were pretty incredible in getting to the root of the matter. I had a GREAT experience with their support.

I can’t say the experience with the forums was the same, but since I do hope it helps someone else in the future, I wanted to come back here and maybe it’ll help someone else out.

It wasn’t my Mac, and it wasn’t the hub. In the end, we tried about 5 different cables, each different port across two hubs (to rule that out they sent me a second docking station to test on) and nothing was working or helping.

Then! We checked the Refresh Rate on both monitors. We were able to 100% FULLY RESOLVE the issue FOREVER by changing the refresh rate on the monitor that wasn’t being ‘seen’ to 50 Hertz from 60 Hertz.

Apparently the 60 Hertz power draw was a little too much for the docking station to support on top of everything I had plugged into it that was all working - Including a Behringer audio interface. The visual difference to the naked eye (well, at least for me) is non-existent, and I haven’t had an issue since.

If you go to Preferences>Display - there you can choose the Refresh Rate for your external monitors, and it might help resolve similar issues.

I would have never thought it would be this, so wanted to share.



Remember please we are not the support here.
We try to help but we are not wiser than the support.
Please apologize!
But great the issue has been resolved and the advice will help others.

Just received this brick (lol). I have a relatively new (2020) dell xps13" and a 2020 dell 34" curved monitor. Without this brick the dongle i use works fine- meaning I have it connected (via lightning port to xps13") with3 USB connections and 1 HDMI (for the monitor) connected to it.

When starting this up in I staggered plugging in the componentrs. Everything works fine EXCEPT HDMI to HDMI for the monitor does not work (no signal from HDMI is the monitor message- from laptop NO DISPLAYS DETECTED). I swapped the HDMI cord, I also tried a Ligtning (from brick) to HDMI (monitor) and it flickers but regresses back to not working. I have little to no patience as this should work seamlessly and if it does not I’ll be sending back and will go with a dell brick (which, theoretically should work fine for these devices).

Has anyone had this problem and solved it? If so what did you do? The support site does NOT appear to have a firmware update and I have not contacted Anker yet (I will once their support team is online). HDMI to HDMI should be a simple thing yet it is not working…

Any advice/guidance is helpful. thanks

Sucks you are having such a bad experience with it, definitely contact support so they can make it right :+1:

thanks warrior and in this case with some diligence it’s now working. Happy to say i was able to narrow the issue down and then with a support call we further narrowed it down and solved it.

Long/short- after some display setting manipulation my 34" dell monitor (connected to the dell xps) would only work if I changed the refresh rate to 30hz. Yet when i connected my macbook pro and when I used the travelport (with my dell xps) neither required that setting changed as both worked at 60hz. The dell soundbar i purchased for my dell monitor only worked if I attached the USB B to USB A (at the hub) and apparently it was not playing nice with the HDMI to HDMI connection when both were connected between the monitor and the hub. Something was messing it up. So, trial and error I disconnected the USB B to USB A and viola the monitor works at 60hz refresh rate BUT soundbar does not. I then tried a lightning (monitor) to lightning (hub) and the whole thing worked fine meaning display and soundbar - no need for HDMI or that old style USB B connection.

I guess the million dollar question is why dell, with a new 2020 34" monitor, would include a USB B to USB A port and further why their slim soundbar would require that connection in addition to the HDMI connection (if that what you were using) in order to work. Seems a bit backward as I learend that USB B is old - frankly i had never seen one of these (cord came with the monitor along with a few other types) and even had a hard time explaining it to the support rep until I found the name of the port on the dell website.

Anyway, it is working just fine now. Combination of determination to get the issue down to 1-2 things plus scrolling through the thread here and finally the support rep got it resolved. thanks all.

Thank you for posting. It helped me fixed the same issue I has having.

1 Like

Thanks for the update. This helped me greatly, however it wasn’t my fix exactly as things have apparently changed in Mac OS 11.4 (running on M1 MacBook Air) so I wanted to post my fix so others would have some insight. In iOS 11.4 you apparently aren’t able to change the refresh rate through the displays control panel. Instead, I had to change my monitor to HDMI standard 1.4 instead of 2.0 in order to bring the bandwidth down to a level the Anker dock could live with. So far no issues but I will update if I have any. It’s disappointing too because it’s a nice looking dock with easy access to everything I need (though would it kill you to add another USB-C port on the back?) just to get this hassle. The el-cheapo dock I was previously using had no issues whatsoever even when running 2 portable hard drives, transferring files from one to another and running the external 4K monitor and a USB amp/DAC combo. I do understand the point that was made about Apple designing a computer with less ports, a hardware company having to ensure compatibility across multiple platforms, etc… but when I remove the perfectly functioning el-cheapo dock and replace with the brand name Anker dock and the trouble starts, I sort pointing my finger at Anker. Hope this helps.

I purchased a new Dell XPS-13 (9305) and the Anker PowerExpand Elite 13-in-1 TB3 DS and have tested all functions of the docking station, USB to USB external HD, SD ports, TB ports and HDMI to a relatively new 19" external monitor. I connected the XPS-13 to the DS via a TB 4 cable (CalDigit). All worked fine. My monitor shows on the Dell and using Sound app could configure to have sound on the notebook, on the monitor and with both. The Docking Station is working great.

I have a similar problem, on a Windows PC.
HP Spectre x360 2019 model, Anker’s dock connected to TB3 port with Anker’s TB3 cable, playlist of streamed videos 2 to 5 minutes long from, external monitor Philips 246V5.
Issue occurs: the external monitor is plugged into anker’s HDMI port (HDMI to HDMI). At the end of a video the external monitor goes black, “no video input”. Change of resolution or refresh rate does not prevent the issue. To get the signal to the monitor back, have to re-start anker or re-plug the TB3 cable from the laptop.
Issue does not occur: the external monitor is plugged into anker’s USB-C to 2HDMI adapter and the adapter is plugged into anker’s USB-C out (to the left of anker’s USB-C to laptop port). At the end of a video the external monitor blinks but continues working. Works for any available resolution or refresh rate.
Any advice?