Anker PowerExpand Elite 13-in-1 Thunderbolt 3 Docking Station / HDMI Problems

Hi All,

I bought by the prime days the Anker PowerExpand Elite 13-in-1 Thunderbolt 3 Docking Station but I get no signal at my external display via HDMI. I tested it by two monitors with the same result. With an ordinary USB-C dock I have no problems and it worked very well. Also I don´t get a LAN connection.

Any Ideas why?

Thanks for your help


1 Like

What is the computer you connected it too?


oh my mistake :frowning:

MacBook Pro 13 ( 2019 )

1 Like

Jaja, this could be the reason.
I dont have such a macbook.
But problems with Apple items happen often.
You should wait till the friends from over the pond show up,.
There are some MAC-Users.

Schönes Wochenende Markus!

1 Like

Hmm that’s weird, hope you can fix the issue

1 Like

I’m having the same issue. It will work sometimes, and then it flakes out, and now it’s not recognizing the display at all. Works with the HDMI port, but not the USB-C port. So straight HDMI to HDMI works. HDMI to USB-C does not work on my Macbook.

Very frustrating, might be getting rid of this thing if it’s just an expensive brick on my desk that doesn’t do the main thing I bought it for.

If you under return option and you got no a satisfying answer to resolve that prob I would give it back.

That’s a normal problem :
Many different devices, many different OS, many different drivers.
Its nearly impossible to get a something working with all those.

I have a pretty standard issue Macbook for engineers (thousands of us) at my company. I don’t think my setup is strange. I didn’t do anything after market. It’s a very basic up to date Macbook Pro, that should have been one of the main machines tested by a hardware device company that claims to support both Mac and PC.

If it’s not supported fully on Mac, it should have been noted.

I’m seeing reviews everywhere that are saying this is an issue on their Macs. I’m guess it wasn’t tested thoroughly on any Mac.

Seems to be an extremely common problem.

There is not only Mac-OS and MS in our world. :grinning:
I never would claim any problems by using LINUX devices.

But you are right with Mac-OS and MS it should work.
Ask the support.

Or it did work once then Mac changed something. Too many variables to point fingers.

Example: Why does your company issue laptops to engineers who need more ports than included?

You see where this goes around in circles, no one org fault once the problems created by the laptop designer.

Not a fan of any company who designed a laptop with so few ports it needs a hub. A hub represents another wrinkle and if not an official hub then this exact problem arises.

Most engineering companies I worked with got Lenovo with plenty of ports and offered a hub they support, called a docking station.

There’s so many combinations of hubs and devices now it’s good luck if anything works, or stays working as software updates. So we just work the problems and not point fingers downstream from the original error of the laptop designer.

1 Like

I will tell you this, I had a MacBook and my 7 in 1 hub worked until the released a new OS and then it stopped working. I stopped using the MacBook and am now using my Windows based laptop and have not had any issues since.
So I believe the fault lies with Macs and their updates, I also know that their new this year MacBook which uses apples own processor does not work with these hubs


Good anecdote.

I don’t think this is really a Mac Vs Windows issue. They both can be broken by software updates, in Mac case by Mac and in Windows case by MS or the device drivers.

This is a symptom of:

  • bad designer who offers so few ports more hubs are caused.
  • bad decision by corporate owners who buy laptops with either too few ports and/or don’t include a hub they force to keep working by pushing tested updates.
  • bad decisions by buyers who think a skinny laptop is a good idea to then have nightmares finding a working hub and keeping it working.

Ultimately the root cause of the whole saga is the hardware design of the laptop. In this case Apple.

1 Like

Oh no don’t get me wrong, I wasn’t trying to make this a mac vs windows issue. I was merely stating how it stopped workingon my mac and I am still able to use it with my other laptop.


Never a device stopped working after installing a new Linux kernel.
Sometimes a program disappears ( no more further adaptation )
So you have to find a replacement…
I often would like to have my old Amarok back. :smile:

1 Like

We’re agreeing (I think).

I’m saying the issues arise “first cause” with a bad hardware design manifesting as a software cause and Anker gets blamed.

The only failure which can be legitimately put to Anker is the vast numbers of hub types they make, it makes each hub less important, therefore less tested therefore fails earlier. I’d expect Windows and Mac to share failures from the many hubs cause.

The notion Mac is blameless and it’s Ankers fault is wrong, I’d say 60% Apple fault, 20% consumer fault, 20% Anker fault (debatable).

I’ve had corporate laptops for 25 years and if I needed more ports got it with the official docking station. That at least is most likely to be tested by the laptop maker as it’s their own hardware. The notion you have a USBC port and hub and devices work is where the consumer shares in the fault. I’m amazed it works at all.


Old laptops old devices -> All works fine with Linux.
But who cares about Linux only some weirdos as we do.
And I am the most Neanderthalian as usual. :joy:

Linux did not penetrate corporate desktops. It only really got popular as a Unix and Windows NT / Server replacement.

Linux users to the most degree are technically more sophisticated, individuals, and that fights the corporate SOE “standard operating environment” intention. With Linux effectively banned it is common for the more technical to prefer Mac as it’s the next best thing to Linux. So I’m not surprised when I hear corporate and Mac and engineering in same context.

But that’s orthogonal, few-ports laptops for the problems intended, cause a hub and causes a layer of complexity which is the root problem.

I can request a hub from my company, that IT suggests, but it’s uglier than this one. I was hoping to have a nicer cleaner looking piece of hardware on my desk than the one supplied by them. But I guess that will not be the case.

I just find it interesting that it works fine on all machines but Mac, and I don’t think it’s mostly Apple’s fault. I think the companies that claim their hardware works on a MacBook Pro, that’s common in engineering, and solves a multi-display problem… it should do that, and it does not.

I think it’s completely reasonable for something like this to be expected to just work. ¯_(ツ)_/¯

Thanks everyone. I came here in hopes I was missing some small trick, or to get some real support. Ah well. I don’t know why I thought that would happen. Have a great day being condescending folks.