Anker Powercore III Elite Help

I’ve had my Powercore for a year now. Couldn’t ask for more. Except I’ve once again encountered an issue I had once before but the old remedy/fix doesn’t seem to be working this time. I had charged my iPhone 12 Pro Max for half an hour or so then left the Powercore, which was 3/4 charged, alone for the rest of the night. Next day when I plug my phone in I get no response from the powerbank. No lights. Nothing. Disconnect my phone and press the button. No lights show. I plug it in to its Anker Powercore charge via Anker cable. Lights circle once. Then twice. Then all of them stay lit and the light just left of the topmost light blinks intermittently but not in the way they do when charging. I had an issue once before where I was able to charge the Powercore fine but it wouldn’t in turn charge any devices. I did the loop usb a to usb c then and it worked. Now that doesn’t seem to fix it unless I’m doing it wrong but I’ve tried every which combination of usb a to usb c for extended period of time and still nothing. Only time I can solicit a response from the unit is when I plug it in to charge via its usb c input and it’s always circles go in one at a time then go on one at a time again then the last light will flash slowly but again, not the way they do while charging which is like a pulse. Any advice greatly appreciated. Also if there’s a specific usba I’m supposed to use when trying to loop it to usb c please let me know it’s been a while since the last time. Thanks in advance