Anker PowerCore 20100mAh resetting and output doesn't work

Yesterday I tried to hook up my Anker PowerCore 20100mAh to my Samsonite suitcase USB port.

Afterwards I noticed that I couldn’t switch on the power bank with the button, nothing happened when I pressed it (even though I was sure it was fully charged). So I hooked it up to a charger and it started to show the first LED blinking. After a short while it showed that it was fully charged.

But now when I plug in a device into the power bank it won’t charge. When I press the button all 4 LEDs switch on for 1 second and then they switch off again. No matter what cable or device I use.
I tried to reset the power bank with the USB cable, but it does nothing. I plug in the cable in the micro USB port and into the USB A port, nothing happens. When I activate the button again the LEDs switch on for only 1 second before it switches off again.
Anyone has any idea what has happened and if it can be fixed?

Charging the power bank shows normal behaviour, but outputting just won’t work.