Anker Astro E1 reset memory 2

Originally posted in the wrong area

I’ve owned an Astro E1 for a few years and it’s been a fantastic purchase, I’m about to buy a replacement as I think it has finally had enough.

It stops charging my phone and thinks it’s empty however when I plug it back in to charge up it starts flashing on the third light for ten minutes and then the fourth light until full. As it only charges my phone for a short while from full I believe the battery memory has stopped working correctly (It thinks it’s empty when it’s still over 50% charged). Is there anything I can do to reset/refresh/drain the battery so I can keep it for a spare ?

Any help would be greatly appreciated,


1 Like

Try plugging the cable into the USB port and the other end into the charge port. This should reset the internals…once done try charging a different device to drain the battery before you recharge it


Hi @Jamie_Lawrence,

Thank you for bringing this issue to our attention via the community.

We regret to hear that this Astro E1 cannot add enough power to your phone and so sorry for any unpleasant experience brought to you.

May I bother you to connect the included micro USB cable to the input and output port at the same time to reset the battery per elmo41683 's suggestion ( @elmo41683, thanks for your clarification)? After that, could you please use another working cable and test another phone to see if the problem persists?

If the Astro E1 still doesn’t work as expected, you can contact us via and we will be more than happy to help you out as per the 18-month warranty policy.

Sorry for the inconvenience caused and thanks for your understanding.

I’ve been having a problem with my Astro E1 charger.
When i plug in my phone the battery pack shows 4 lights but then drains to 1 flashing one within a few minutes. When i plug it back into my laptop to charge it jumps right to 3 solid lights. After a short while it is showing fully charged, then this all happens again.

I’ve seen something about resetting the memory but not sure if that is doing anything or if I am doing it right.

Please help :blush:

1 Like

connect the a micro USB cable to the input and output port at the same time to reset the battery. If you are still having trouble send a email to provide them with the serial number and order number and let them know any trouble shooting steps you have taken and they will help the best they can and assist with warranty if still available

Hi @bharmande,

Thanks for contacting us and letting us know your issue.

It seems you have the same issue with Jamie_Lawrence. Please confirm once again whether you have tried the following troubleshooting to see if the problem can be solved.

“use the included micro usb cable to connect the input and output port at the same time for 3-5 seconds to reset the battery and then recharge and discharge the battery again.”

If not, please contact us via, we are more than happy to assist you.

Have a nice week.

1 Like

Thanks @AnkerSupport. I have always wondered how long does cable sneed to stay connected for an internal reset. Good to know its 3-5 seconds. :thumbsup:


I have an 2nd génération Astro E1. I’ve the same problem for a few days. When I plug my full charged Astro E1 to a device, the four lights come up from the bottom up then nothing is happening. The screen of the device does not show it’s charging.
I tried to apply the procedure given above but without success. Nothing is happening.
Can someone help me?


1 Like

Have you tried using a different cable? If not then I would start there and see if it’s the cable, also see if you can charge other devices, of course using a different cable as well.

Of course I´ve been trying with several cables including the original one and dite several devices and is it still the same!

1 Like

can anyone tell me what I can do?

1 Like

It may be time to get a new one, how old is it? If it’s within 18 months of when you purchased it you can reach out to for warranty exchange.

Ok thx, lost for me it’s 20 months old :pensive:
Any suggestion to buy the same product about the same or better?

1 Like

That’s a shame. The powecore 13000 is super nice. I would highly recommend it.

I wrote a review for it on my personal blog if you want to read it.

I have the same problem, I bought the E1 in 2018 but I only got to enjoy it for two months before it started exhibiting the symptoms. I don’t know why would Anker release a defective product in the market.

I had the same problem about a year ago.
I’d used it only a handful of times when traveling (going months between use), and then right after the 18mo warranty expired I got the same error as all of you.
The Anker rep I spoke with said nothing about this known error, nor to try the reset. Just said I was out of warranty and need to buy a new battery.
Because of that bad experience I decided to avoid buying anker batteries in the future.

That said, I’ve not had any problems with their cables, so I still buy/recommend those, just not the batteries. It’s a shame because I really thought they made high quality products until this battery problem.

My astro E1 had the same problem after 21 months. The reset made no difference. I had only used it 4 or 5 times. So very
Disappointed with Anker. Previously I have been a fan of the Samsung S5 battery and case. But these Asto e1 cells seem to suffer unreliability and poor service life. I will not be purchasing anker power banks again.

My 2nd Gen Astro E1 had the same issue as described by the original poster. It would show a full charge but would only discharge for about a minute before no longer providing a charge to the connected device. Upon plugging the battery pack in to recharge; three to four lights would illuminate to indicate that it wasn’t fully discharged.

I was about to recycle the battery pack, but I was able to reset it by plugging in a cable to both the input and output ports. It is now working fine.