Soundcore Life Q20 and mic not working on linux

I have a pair of Q20 and cannot get the mic to work on linux.
As much as I found out the problem is that the headphones report only as handsfree (HFP), not headset (HSP):
Here are the capabilities of Q20:
0000110b-0000-1000-8000-00805f9b34fb Audio Sink
0000110c-0000-1000-8000-00805f9b34fb Remote Control Target
0000110d-0000-1000-8000-00805f9b34fb Advanced Audio
0000110e-0000-1000-8000-00805f9b34fb Remote Control
0000111e-0000-1000-8000-00805f9b34fb Handsfree

For another headset where mic is working:
UUID: Vendor specific (00000000-deca-fade-deca-deafdecacaff)
UUID: Serial Port (00001101-0000-1000-8000-00805f9b34fb)
UUID: Headset (00001108-0000-1000-8000-00805f9b34fb)
UUID: Audio Sink (0000110b-0000-1000-8000-00805f9b34fb)
UUID: A/V Remote Control Target (0000110c-0000-1000-8000-00805f9b34fb)
UUID: Advanced Audio Distribu… (0000110d-0000-1000-8000-00805f9b34fb)
UUID: A/V Remote Control (0000110e-0000-1000-8000-00805f9b34fb)
UUID: Handsfree (0000111e-0000-1000-8000-00805f9b34fb)
UUID: Phonebook Access Server (0000112f-0000-1000-8000-00805f9b34fb)
UUID: PnP Information (00001200-0000-1000-8000-00805f9b34fb)
UUID: Vendor specific (81c2e72a-0591-443e-a1ff-05f988593351)
UUID: Vendor specific (f8d1fbe4-7966-4334-8024-ff96c9330e15)

As you can see, they have both HFS and HSP.

Will there be a firmware update that woudl enable HSP on Q20?

Thanks,
Ivan

1 Like

There are not many LINUX-users here, Ivan.
I dont own these Q20 so I can not test.
Hope there is someone you get help from.

I managed to get it to work, but it involves few more programs running in the background…
That is why I was wondering if this can be fixed in software (firmware) or is it a chip limitation.

LINUX and Bluetooth is always a mess.
But if you got it to work be glad about!:wink:

Any hints how you solved it?
I have the same problem…

Well, I used these two websites:
https://www.freedesktop.org/wiki/Software/PulseAudio/Documentation/User/Bluetooth/#index5h2
https://wiki.archlinux.org/index.php/Bluetooth_headset#HFP_not_working_with_PulseAudio

You’ll need to install ofono and phonesim and, if you follow instructions from the websites listed above, you should be able to make it work. If you have any problems let me know and I’ll try to help.

Thank you very much

I’ve already read websites but I had some errors during the process.
I’ll try again.

I’m using Ubuntu 19.10 and I had issues installing ofono and phonesim.

Also, what is the difference between the two links? The instructions look similar. Did you do both?

The first link are the generic instructions from PulseAudio, the second one are the specific instructions for Arch linux and they are more or less the same. One major difference is that Arch instructions specify commands to bot enable and power on the phonesim modem, in PulseAudio instructions they are just power it up and say it is also enabled.
What kind of problems are you having with installing these two packages?

Thank you! That worked!

Finally I managed to install ofono and phonesim and make it run. Although, I realized that it doesn’t work perfect.

E.g. when I restart my computer, the microphone don’t work and I have to start phonesim again.
I can put the command to run on startup though… Do you face the same issue?
Also, sound is not so good in HSP/HFP mode

Starting the program when starting LINUX is a simple, good solution.
Sometimes needed when those issues show up.
Perfect solution, helpful for many others.
Thank you.

Yes, you’ll have to start ofono and phonesim every time you restart the computer. I am not using the mic that often, maybe once per week, so I just start them when needed. If you use it regularly you can make a short script to start phonesim and then send dbus commands to enable the modem. That was also the reason I asked this question in the first place: if headset had HSP mode, not just HFP, it would work without ofono/phonesim.
The quality is definitely worse if HFP mode, use it only when you really need it.

Hello how did u manage to install ? I am on ubuntu 20.04 and not able to install phonesim-ofono package due to Qt libraris missing…

I found all libqt packets there as well.

any ideas ? I am new to synaptic.
Thanks for your answer.

I think 20.04 is not supported, and manually installation is not working for me because of Qt version, I am currently at 5 and not able to install Qt v4 anyway. :worried::worried:

Install that ofono and/or ofono-phonesim.
The needed libqt packages will be added automatically.

That would need a lot of “LINUX-talk”.
And many more screenshots.
Better you change to a LINUX-Forum.
Those remote diagnosis is quite difficult.
(And I am not using UBUNTU)
But the packages offered by SYNAPTIC should be the same.

Hi all, I confirm the same problem with Souncore Libery 2.
I’ve fixed for now using what described here https://wiki.archlinux.org/index.php/Bluetooth_headset#HFP_not_working_with_PulseAudio
For Ubuntu Focal, you need to build phonesim from sources (https://git.kernel.org/pub/scm/network/ofono/phonesim.git/)

1 Like

Thank you for the hint for LINUX users.

There is more to read about that package!

https://packages.debian.org/de/sid/devel/ofono-phonesim
http://manpages.ubuntu.com/manpages/bionic/man8/ofonod.8.html

Unfortunately I have the same problem. I am using Fedora 32. I followed the instruction here;
https://wiki.archlinux.org/index.php/Bluetooth_headset#HFP_not_working_with_PulseAudio

However, the volume is very high and I can’t control. The quality is also very bad.

The packages I have installed;

pulseaudio-13.99.1-3.fc32.x86_64
bluez-5.54-1.fc32.x86_64
ofono-1.31-2.fc32.x86_64
phonesim-1.21-1.fc32.x86_64

pactl list output

Card #2
    Name: bluez_card.88_D0_39_81_08_86
    Driver: module-bluez5-device.c
    Owner Module: 26
    Properties:
            device.description = "Soundcore Life Q20"
            device.string = "88:D0:39:81:08:86"
            device.api = "bluez"
            device.class = "sound"
            device.bus = "bluetooth"
            device.form_factor = "headset"
            bluez.path = "/org/bluez/hci0/dev_88_D0_39_81_08_86"
            bluez.class = "0x240404"
            bluez.alias = "Soundcore Life Q20"
            device.icon_name = "audio-headset-bluetooth"
            device.intended_roles = "phone"
    Profiles:
            a2dp_sink_sbc: High Fidelity Playback (A2DP Sink: SBC) (sinks: 1, sources: 0, priority: 40, available: yes)
            a2dp_sink_aac: High Fidelity Playback (A2DP Sink: AAC) (sinks: 1, sources: 0, priority: 40, available: yes)
            a2dp_sink_aptx: High Fidelity Playback (A2DP Sink: aptX) (sinks: 1, sources: 0, priority: 40, available: no)
            a2dp_sink_aptx_hd: High Fidelity Playback (A2DP Sink: aptX HD) (sinks: 1, sources: 0, priority: 40, available: no)
            a2dp_sink_ldac: High Fidelity Playback (A2DP Sink: LDAC) (sinks: 1, sources: 0, priority: 40, available: no)
            headset_head_unit: Headset Head Unit (HSP/HFP) (sinks: 1, sources: 1, priority: 30, available: no)
            off: Off (sinks: 0, sources: 0, priority: 0, available: yes)
    Active Profile: a2dp_sink_aac
    Ports:
            headset-output: Headset (priority: 0, latency offset: 0 usec, available)
                    Part of profile(s): a2dp_sink_sbc, a2dp_sink_aac, a2dp_sink_aptx, a2dp_sink_aptx_hd, a2dp_sink_ldac, headset_head_unit
            headset-input: Headset (priority: 0, latency offset: 0 usec, not available)
                    Part of profile(s): headset_head_unit

The output of power and activate modem;

 #dbus-send --print-reply --system --dest=org.ofono /phonesim org.ofono.Modem.SetProperty 
 string:"Powered" variant:boolean:true
 method return time=1590077704.619661 sender=:1.270 -> destination=:1.271 serial=47 reply_serial=2

#dbus-send --print-reply --system --dest=org.ofono /phonesim org.ofono.Modem.SetProperty string:"Online" variant:boolean:true
method return time=1590077710.250753 sender=:1.270 -> destination=:1.272 serial=77 reply_serial=2

Thanks for help in advance.

I’m having the same problem with my Soundcore Life Q20 in Ubuntu with KDE Plasma 5 here. The phone is working fine as an output device, but its microphone won’t work, it won’t show up in “System Settings -> Audio -> Recording Devices” nor in pavucontrol. Has anyone had any luck fixing this? Thanks.