Soundcore Life Q20 and mic not working on linux

I know LINUX and bt is horrible.
But it can be done.
Great you got it fixed at last.

Guys i had the same problem with Ubuntu. I downloaded pulseaudio and then i could change output. Perfect audio.

The headphones work with Pipewire.

For Ubuntu based distros, you can follow the instructions here:

It’s a good idea to add bluez5.msbc-support=true in /etc/pipewire/media-session.d/bluez-monitor.conf to enable SBC as otherwise the microphone quality is poor.

2 Likes

Good to know!
Thank you for information!

1 Like

Hey Ivan! Thanks for sharing your experience with the Life Q20.

It appears as though this is a compatibility issue between the Life Q20 and the Linux System. We recommend you try connecting your Q20’s to different systems, such as Windows and iOS, to see if the issue persists.

If possible, you can also reach out to support@anker.com with a message detailing the issue and your order information, and they’ll be sure to help you further!

Cheers,
The Anker Team :slight_smile:

Hello,

I’m using Linux Mint 20.3 and I have installed PipeWire using this tutorial . After installing the sound was not working , but peplacing the /etc/pipewire/pipeware.conf with /usr/share/pipewire/pipewire.conf and rebooting the computer solved the problem. Now I can use my SoundCore Q10 mic - you must also change the profile from volume control for the Q10 to Headset Head Unit for the mic to work.

1 Like

Hi Marius,
A Linux mint user here!
GREAT!:grin:

I have recently installed a system wide eq called "PulseEffect"s.
That’s more than a mighty tool I am still playing around with.
There are not many Linux users around here,
so I am glad to meet you.
BTW. I am using speakers only.
Do you know that tool?

1 Like

I made a mistake in the previous post. You must copy all the files and directory from the /usr/share/pipewire/ to the /etc/pipeware/ directory ( sudo cp -R /usr/share/pipewire/ /etc/pipeware/ ) and having problems with the microphone ( poor quality when I don’t speak loud ) I have enabled in /etc/pipewire/media-session.d/bluez-monitor.conf bluez5.enable-msbc = true as explained in a previous post. Now everything works excellent. Even in the upgraded Linux Mint 21 ( you must redo the configurations after the update )

I don’t know the tool, but it sounds interesting for someone who “plays” with audio. I don’t work with audio, I just wanted my Q10 mic to work in Linux. Maybe if I will have time I will take a look at the tool. Thank you for the suggestion.

Do it, it’s worth it.
It’s the best audio tool I came in touch with.

I have two Flare minis (TWS) in my pensioner’s office
The sound is incredible for these little speakers.
And what most important, there is an adjustment for “latency”.
Works perfectly.
Not to be found at Win or Mac-OS audio tools , if there are really any to be mentioned :laughing:, though they ask money for their perfect OS’ offered :innocent: