Nebula Mars 2

I’ve been using my REPLACEMENT projector that Anker sent me after the first one I had became defective and it decided to not turn on one day. I’ve done everything customer support told me to do, and it will simple not turn on. I have no idea why, been using it for 6 months and it has had zero problems until now. Really pissed off because since it’s the replacement, I no longer have any warranty. $420 out the window.


After using two alternate chargers and the various way to getting it powered on, it seems that there is no sign of life. This projector has straight up died. Thanks Anker.

Note: I really like the display and portability, but even separate from it braking down, I don’t think it’s worth its price tag. Anker really needs to listen to complaints and look at the root of the problem.

1 Like

Sorry to hear that, what did customer support tell you to do?

All they said was try the reset button and hold for 3-5 seconds. I’ve already done that by looking at the manual. I literally don’t know why it stopped working l. I came downstairs one day and saw that out of the four led lights, the second one was on. Sliding down the lens wouldn’t turn it on, so I tried a reset. All the led lights are off since then. I’m so mad.

What kind of cable does it use? Did you try a different cable just in case

I had this issue and its because of the power plug. It develops a grounding issue and causes the projector to not turn on…this assuming its the same issue. Unplug the power cord, press and hold the reset button for 10 seconds and then slide open the lens cover and it should turn back on.

If it doesnt turn on, then open and close the lid really fast 3 to 5 times and see if you hear the fan spin on. From my experience once i have opened and closed the lid in rapid succession it would turn on. The plug needs to be replaced in this case

Thanks for your help.

Have you been able to get it to work?

Nope. I actually updated my post if you want to check that out. Idk dude I just hate the way they made the powering system. Like why not have a button??

Exact same issue here. Read on another post that using a hairdryer to warm up the unit makes the fan kick in and the projector then starts up. Sounds crazy but worked for me.
I am going to contact anker support as I’m on my second one , the previous had a software fault , and it seems this is a common experience of other customers.
Apart from that - it’s a great projector!

I have the same issue. Bought in India last year. Due to Covid, widely using it only after few months of purchase. No actual support from customer care so far. Mars 2 is the model and it’s randomly switching on/off. Could someone help please. Much appreciated.