Liberty Air 2 Mic Muted During Call

Anyone else having this microphone muting during a call? It’s not bluetooth dropping as I can still hear the other person, they just can’t hear me.

During call 1: using phone app to call, it muted me in under 1 minute.
During call 2: WhatsApp to call, it muted me after 20 minutes.
During call 3: WhatsApp to call, it muted me in under 2 minutes.
During call 3: WhatsApp to call, it muted me in under 2 minutes.

Will continue to update my call situations. In all cases, I hear them. They can’t hear me during mute. Any suggestions or maybe because I accidentally touched the earbud somehow? (very sure I didn’t…)

1 Like

During call 4: Snapchat voice call, muted at 20 minutes BUT looks like double tapping the left OR right ear bud unmutes it. What does the function for double tap during call do? Anyone know? The mutes happen so randomly it seems though.

1 Like

It could be the earbuds shifting away from your body and the sensor thinks you removed them from your ear. Try to disable the automatic pause, you can do so in the app and then try your phone calls again and see if it still happens

1 Like

I appreciate this suggestion, will update after some more call testing. During my 4th call it kept muting every 30 seconds. I just kept double tapping to “unmute”. With Snapchat call, I can see my mic volume picking up so I know when I am muted to be able to “unmute” myself. :slight_smile:

1 Like

So far I’ve had 2 successful calls, both roughly 3-4 hour calls straight with “automatic pause” feature in-app OFF. It seems to have fixed the issue completely. Will update IF it happens ever again otherwise anyone reading this, it MAY be the fix if you have the same issue like me. I personally don’t care for the “automatic pause” feature. I am happy with just double tapping to pause. Thank you @Tank for the suggestion!!!

1 Like

What Phone device are you using?

Also when you say muted is it

  1. the app you’re using shows that your mic is muted

  2. no software indication you are muted but the other party can’t hear you

1 Like

Device: Galaxy S10+

  1. Snapchat does have on-screen button to mute your microphone, this wasn’t it
  2. on WhatsApp my friend would keep saying “hello” and I can hear him but he can’t hear me which I had to recall. On Snapchat calls, it shows your microphone voice bar go up and down so it was flat while I was speaking loudly to be able to know if I was muted or not, even though Snapchat has a mute button that wasn’t what was happening.
1 Like

Glad it’s working for you, I too am not a fan of the auto pause…but it does have its uses so for now I keep mine enabled. Besides I don’t really talk in the phone much, so it works for me either way

This is happening to me as well. I turned off the auto pause but it appears that the problem still happens although less frequently. I use these headsets for work and am on the phone for at least 50% of my day so this is a pretty big problem.

I sent an email to Soundcore support and they said
“After we receive the serial number, we can help you do the upgrade through the APP to solve these issues you met with the headphones.”

I’ll send an update on this thread after I hear back from Soundcore Support.

1 Like

Soundcore support sent across a firmware fix. Unfortunately the problem still persists. They are going to exchange the earbuds for a new pair as they suspect it may be a defective unit.

Hope it works as I do like these earbuds.

1 Like

I’m on my second pair of buds. Both have the muting problem. I noticed that it happens more when I have both buds in my ears. And when I put one back in the case, and immediately pull it back out, it unmutes. I’m on a galaxy note 8. I purchased these 99% for call as I’m on the phone 8+ hours a day. I’ll give these another chance, and am extremely open to suggestions because I love everything else about them.

1 Like

Have yoh turned off autopause in the app? This way it doesnt pause if it senses movement as if you removed them from your ears

1 Like

I just got the Liberty Air 2’s. I just got them today and paired them with my Galaxy S10+. Music plays fine. When on a call though, I can hear the other person, but they mostly can’t hear me, its random if they can hear me or not. Incredibly frustrating as I’m trying to work today.

1 Like

Joined to say I’m having the exact same problem. Anker support have exchanged one pair of buds, and tried a firmware fix.
I’ve disabled autopause and also tried disabling Google assistant which I’ve heard can cause bluetooth dropouts. As everyone has said though, I can still hear the other person so it’s got to be microphone, not BT surely.
Will hold out for a firmware fix / update from Anker for another week or two, but then will be forced to give up and return them.

1 Like

Dear supporters,

There will be a beta firmware to fix this issue in the next one week, please reach out to us at soundcore@service.com for any help.

@chris229 @Tank @Satoru @Jon62 @Jonathan_Daly @talibanhater @chris229

Thank you for your time!

1 Like

Has there been any resolution to this? I am experiencing the same problem. I emailed Anker support as well.

@James105 - Anker released the updated firmware on Sunday night. I’ve been on the phone for a little over an hour since I installed the new firmware and so far have not experienced the muting issue. Will continue testing.

Is it 04.19? I have that too and I was still experiencing the issue as of yesterday.

@James105 nope it’s 4.20 you need to contact support as it is not public release. I believe they are only sending it to people who have the muting issue.

1 Like

Awesome, thanks so much!