How do I get my headphones to stop disconnecting from my android phone? Soundcore Life Q20

Just got my headphones in today after ordering. The headset is working well aside from one problem:

Every so often they just disconnect from my phone. I’m using a Samurai Kiwami, and from what I can tell there are not any hardware conflicts. Is there anything I can do to stop this? Pairing the device to my phone repeatedly doesn’t work and there doesn’t appear to be any updates or bug fixes or anything to solve the problem that I can find

2 Likes

We are sorry to hear your headphones are not working properly. According to the information you described, the issue you are experiencing is very unusual. Please try the following steps to see if it helps at all.

  • Confirm the headphones are fully charged (the indicator will charge until it’s a steady blue)
  • “Forget” the headphones in your device’s Bluetooth history
  • Reset the headphones by holding the “Call” and “Play” buttons for 5 seconds while the headphones are charging.
  • Try pairing it with another device.
  • Ensure there are no physical objects hindering the Bluetooth connection from the headphones to the device they’re connected to (such as a doorway or wall…even in a pocket can cause interference)

If the issue still persists, don’t worry, please don’t hesitate to contact us at service@soundcore.com by detailing your order number and the problem you come across. We will reply you within 24 hours.

I have the same problem with my Lenovo Chromebook C330. The headphones will just randomly disconnect . I’ve tried forgetting all pairings and pairing again, but no luck. So far, it seems to be working with my Samsung Galaxy A50

1 Like

I’m Also getting the same issue with the Q20. Happens multiple times a week where the bluetooth just turns off, and you have to switch the headphones off then on again. This has occured with both my Lenovo t480 laptop, and Android phone.

2 Likes

I get the same problem keeping the Q20 connected to my work computer, a Lenovo Latitude 7400, Core i5-8365U 64-bit running windows 10. Annoying on Teams calls especially, can’t restart and reconnect in that situation.

I just bought this headset and it is happening to me too. It’s getting so annoying. I have an iPhone XS Max with iOS 14.1 and I will be listening, just about every 20 minutes I lose connection. Music just stops playing and the headphones disconnect. Please tell me how I can fix this as the sound quality and noice canceling is great in these. Better then my $200 Sony’s, I gave them to a friend now that I got these thinking they would work. The issue is I cannot even use these like this, please help me, it’s so annoying. I’m starting to get really pissed.

2 Likes

I’m having the same problem with my Pixel 3. Was on a call with Discord and my headphones randomly disconnected without warning several (at least 4) within an hour.

They also disconnect at least once a day from my MacBook Pro, which is a major pain because it also knocks out my bluetooth mouse’s connection for around a minute, and I have to fiddle with turning things on and off to get it all back online. It’s really disruptive during calls!

I have the same issue, microsoft surface laptop, LG v50 phone. Looks like its a very common issue with this device, I’ve not had the issue with my other headphones

Did anyone find a solution? I guess i’ll have to return, but thats such a shame because i otherwise like the headphones

Android and other OS don’t like sharing Bluetooth with laptops.

Delete all pairings. Turn off all device Bluetooth.

Reset the headphones.

Turn on the Bluetooth of the one device you’ll use with the headphones.

Pair with just one device only, use with one device only.

I suspect yes that might be the issue. But why can’t the Q20 cope with being paired to multiple devices even though my cheap £15 earphones and my other headphones in the same price range can (and those devices do not claim to have multipoint either).

Also, anker support said being paired to multiple devices should not be an issue.

shame really

I suspect it’s related to same Vs different Bluetooth versions and protocols. I can pair with two Android devices and works but not Android and a laptop. Certain combination work.

Multipoint is where you can handle a variety of combination, without that it’s down to luck. Read this, it goes at little deeper. I found the worst combination was never pair with a laptop and expect it to work with anything else.

I know I am stepping in quite late in this conversation. I am going to share my experience anyway that may help other people in the future. So I had faced a similar problem yesterday. I bought these headphones a week ago. They were working brilliantly. I had multiple devices connected. Everything was just fine until yesterday when I picked up my headphones in the morning while began working on my project. I like listening a light music to avoid outside noise/ distractions. The headphones started disconnecting very often like in 3-4 mins of playback. Got worried. After a few hours of struggle I thought I would return them. This morning, when I sat down to make a return request. I decided to try them one more time. I noticed when playback stopped my headphones were still connected to Bluetooth to my laptop for a while, then after a few seconds it turned off. I checked the battery. I disconnected from my laptop and then paired again. I reset the headphones. Everything seemed normal and then finally I noticed I had a mic icon in the notification area. I had my zoom application open. I closed the application, restarted my laptop and when they connected again; they have started working normally. Hurrah!

So my fellow users, if you have any application open that uses microphone it could interfere with your headphones. Please check for skype, zoom or such any other application.

Thank you for reading. I hope this helps!

1 Like

Thanks for the update, laptops seem to be a consistent issue for all products, not just Anker / Soundcore, multipoint kind of works only in special situations, the laptop supports two modes and will flip between them based on the app, that confuses the bluetooth device and causes product specific effects.

There are many threads here and in soundcore community which involve laptops.

The most reliable solution across any product is to dedicate a bluetooth device to the laptop. Some get lucky with exact combinations working perfectly.

1 Like

Having the same issue and it is incredibly frustrating. I just purchased these a month ago and it keeps randomly disconnecting form my surface pro and have only paired it to this device. It is sporadic and annoying.
Considering returning at this point. It’s not the battery either as it’s happened fully charged…

Having the same problem.
Have the headphones for 3 days.
First 2 days were brilliant. No problem at all.

Yesterday and today all day in Zoom Calls - but today it disconnects around 1-3 times per hour. Very frustrating.
Then i have to re-connect Bluetooth Computer and Q30.
Have newest Firmware - what should i do?

Q20 or Q30?

Different products.

If Q30 we need to move discussion to a Q30 thread to help any fix which works for you to be found by others after.

Thanks for the quick answer. Yes you are r ight. Different model but same problem. I am having Q30

Ok I’ll replied to you in a Q30 thread

Thank you for this. I thought this was the answer after exiting zoom from the background, but still had issues. Then I thought maybe it was the alexa tap I had paired with my tablet, and disabled that. It seemed to get a bit better, but still, just randomly shuts off. Something’s not right, it’s my 2nd pair and they do the same thing.