Eufy SpaceView baby monitor issues since 2.4.4

Since I’ve updated the SpaceView Baby Monitor to the 2.4.4 firmware the camera (in her room) will beep randomly and the monitor loses connection and beeps during the middle of the night. Last night… THREE TIMES… We got it as part of the baby shower in June, our girl is almost 8mo old now but this camera / monitor has become very problematic in the last month.

I originally searched for new firmware because the battery life is fairly abysmal anymore and I was hoping that’d fix it a little bit. It did not and now has added those other issues i’ve mentioned. On top of all that the plug-in for the monitor seems loose? have to have the cable in there perfectly or it’ll stop charging and then start beeping at us again because the battery is about to die even though it’s plugged in.

IDK what the new “S” model does differently but maybe some of those issues were addressed?
Can I get the old firmware anywhere? Or how do we go about getting a new better unit? I just emailed support at 4:15 am last night as I was awake most of the night but no response yet.

Hi @Chuck_Reynolds as there is no hardware reset option I can see, which can often resolve product issues post firmware update, the best option would be to contact support on support@eufylife.com or support@anker.com, please allow up to 48hrs for a response via email.

You can also contact via the live chat feature or telephone on Eufy website here https://www.eufylife.com/contact

Hey @Chuck_Reynolds !

So sorry to learn about this firmware issue for this case.

If possible, could you please send us a short video reference to support@eufylife.com? We will assist you with this case.

Thank you so much for your patience. Looking forward to getting you taken care of as soon as possible!

I’m surprise to find this post. I’ve had the exact same problems and after contacting the Eufy support, I couldn’t get any help. Can we have an idea if this is a broader problem related to firmware 2.4.4? Or is it confirmed that it’s a specific issue with some units?

Thanks -

Same issues here. Just got it yesterday and I don’t understand why it keeps beeping here and there.