Drop sensors are dirty error, but they are CLEAN, HELP!

Eufy Robovac 30c, two of them, one purchased June 2019, one purchased March 2019. Run daily.
Both of them are now, every time they run, giving the “Drop sensors are dirty” error at some point in their cycle. When I get home from work, they are just sitting dead in the middle of a room. Not stuck under anything, not hanging over any stair edges, just in the middle of a carpeted room, stopped, shut off. Without doing anything to clean them, I press the start button and they finish their cycles without any further errors.

I clean them after EVERY run - empty the dust bin, wipe the sensors, clean the roller, clean all the wheels. Every other week, the filter media gets washed, dust bin washed, entire vac wiped down with soft cloth.

These vacs have been babied, yet they are now both giving this error every time they run.

Is there any solution to this? It really defeats the purpose of being able to run them when I’m not home.

Open the battery case.
Remove the battery and insert it again after a minute.
This is a kind of reset.
May be this helps.

I’ll give it a try, thank you.

I contacted support with this information, and they suggested that I SMACK the bumper, really hard, since there are sensors under there that might be dirty. I wasn’t too comfortable with abusing the vacs like that, so they also suggested that I could remove the bumper to clean underneath it.
I ended up cleaning the whole vac using compressed air instead. WOW did that ever blow a lot of dust out from the wheel cavities and from under the bumper.
Today, the vac ran its full cycle without any “drop sensor dirty” errors. Hooray!

Welp. That only worked for exactly one cleaning cycle. Next cleaning cycle, both vacs stopped within 5 minutes of starting with a dirty drop sensor error. Took the bumper off, it was completely clean under there, as were the drop sensors. Time to escalate this with support.

Have you tried the reset by removing the batteries?

gah! Not yet. I got sidetracked with the cleaning. I did try to remove it, but the connector would not let go, and I was too lazy to go find pliers to help me with it, so I went the cleaning route.
I’ll give it a try and see if it makes a difference.
FWIW, I just checked and today’s cleaning cycle ran without issues, so I guess this is something intermittently annoying.

Give the robot more a chance.
Ultima ratio would be to remove the batteries.
Unplug. There is nothing you can do wrong! :smiley:

So far, so good - both vacs completed cycles without drop sensor errors today after having had their batteries unplugged/re-plugged.
Let’s see what happens tomorrow!
Thanks for the tip :slight_smile: