Anker Soundcore Liberty Air left earbud not connecting

Soundcore

#1

Hi Guys,
Today I received my Soundcore Liberty Air from Amazon and the first Impression of the packaging and quality of the earbuds are very good.

Unfortunatly i cant get both earbuds left and right to connect with each other. Music is only coming out of the right earbud.
Through the Audioqueues when turning the left earbuds on or off i know that the left earbud is not completly broken.

I resetted the earbuds a few times already and still the same problem.

When i try to set the earbuds up, the right one blinks fast ready to connect with the phone, and the left earbud keeps slowly blinking “breathing”. Manual says its in connection mode. But it doesnt connect to the right earbud.
Connection isnt happening and after about 3-5 minutes are over they automatically turn off due to lack of use.

Is there a solution to this? thanks very much!


#2

When you say you have tried resetting these what method did you use?

Give this a try:

  1. delete the Bluetooth profile from your phone.
  2. Put both earbuds into the case…wait a few seconds then proceed to step 3
  3. Take out the right earbud and tap the side 4 times, then out back into the case.
  4. Remove the left earbud and tap the side 4 times, then out it back into the case.
  5. Take both out of the case at the same time, you will see the lights on top flashing white or blinkin in a breathing way.
  6. Once the earbuds start this or flash red, reconnect to your phone and enjoy your music

#3

Thank you for your reply.

I tried the method in the Manual that was included which was similar to yours.
I tried your method now and it didnt work either. Still only the right bud playing.

After i reset the earbuds and connect them to my phone, the left bud LED continues to “breathe” in white and doesnt play music.


#4

You can send support@anker.com a message and see if they can help you. Alternatively I know a few people who had issues and just exchanged then for another pair and haven’t had any issues since doing so.

Either way I’m sorry for your troubles and hopefully you can get this resolved by contacting support


#5

I have the same problem. Did you manage to get the left one to work eventually? I’m still trying to fix mine


#6

This happened to me as well. I followed the steps 3 times and it didn’t work until took both buds out of the charger and placed them BESIDE each other when I paired them with phone and then it worked perfectly. Hope this helps.


#7

After struggling for about an hour, I tried the reset procedure but instead of resetting the left earbud first Ike in the video I reset the right earbud first, followed by the left. Worked for me!


#8

Hi,

So, I did per as the instruction manual but that didn’t really work at first. Try this

  1. Unpair from bluetooth
  2. Take them both out and tap four times each side - it should blink red on each side.
  3. Put it back in the case.
  4. Take them out and put them next to each other (like literally side by side).
  5. Leave it for a bit (it’ll blink white a lot)
  6. After say a good 5-10 seconds, pair it again to bluetooth.

Hope it helps!


#9

THIS IS FOR THE LIBERTY AIR MODEL #soundcore A3902
Since they have 2 versions for this headphone, could you please check if the serial number is printed inside the charging case or attached via a sticker on the USB charging cable? You may refer to the attachment to find the serial number.

If the SN is printed inside the charging case, please try this method:

Step 1. Delete “SoundCore Liberty Air” from your device’s Bluetooth list, and turn off the Bluetooth on your device;

Step 2. Place one earbud in the charging case and make sure it’s charging (The LED indicator will be solid white)

Step 3. Tap and hold the multifunction touchpad of the earbud (currently in the charging case)for 7 seconds until the LED indicator flashed 3 times. This clears the paring information.

Step 4. Put the other earbud in the charging case and repeat Step 3.

Step 5. After the pairing information is cleared, take both earbuds out of the charging case and place them next to each other.

(If pairing is successful the LED indicator on the left earbud will start flashing slowly and the LED indicator on the right earbud will flash rapidly.)

Step 6. Turn on Bluetooth on your device and search for “SoundCore Liberty Air” to connect.

If the SN is on the white sticker on the USB charging cable, please try this method:

  1. Remove the right earbud from the charging case. After your phone has connected to Liberty Air, delete it from the list of paired devices. Turn off the Bluetooth. You will see a white light rapidly flashing on the right earbud.

  2. Quickly tap the touchpad on the right earbud 4 times. You will see a red light. If there is no red light, tap 4 times again. Put the earbud back into the charging case.

  3. Remove the left earbud and quickly tap it 4 times. You will see a red light. Put the earbud back into the charging case.

  4. Remove both earbuds from the charging case and place them near each other. If the reset was successful, a white light will flash quickly on the right earbud while the light on the left earbud will flash slowly(breathing-like).

  5. Turn on the Bluetooth on your device and find “Soundcore Liberty Air” to pair them.


#10

See my response to below


#11

Sorry I couldn’t resist.


#12

Hi Guys,

I tried the method in the Manual that was included which was similar to yours.
I tried your method now and it didnt work either. Still only the right bud playing.
After i reset the earbuds and connect them to my phone, the left bud LED continues to “breathe” in white and doesnt play music.

Is there a solution to this? thanks very much!


#13

You need to disable bluetooth, and do not pair them to your phone until they connect to eachother.
Try this


#14

The instruction for SN printed inside the charging case is ONLY one that works for my liberty.

Thank you !!


#16

Please do not post spam links or links to external sites that can be deemed unsafe
@ndalby


#17

This suggested worked perfectly after trying all others! Thanks for posting :smiley: