Zolo Liberty+ Issue - Lower volume on right bud

:nauseated_face:sounds pleasant

I got the same issue few days ago, i can barely hear anything on the left earbud and on the right the sound is too low.
it is really frustrating and the earbuds are useless now.

As you found the root vause, how to fix it now and when?

I’m also experiencing near total loss in volume in my right earbud. Any response from Anker/Zolo?

Send zolo a message, that is the only way you will get a solution and help. We can post about it here but in the end we about ll have to reach out to them for support and warranty


Yep - problem started appearing yesterday and now almost silent in the right ear. Since most problems appear in the right earpiece (judging from posts above) I’d say this is a tech issue and not so much a wax/oil issue. Will email Zolo support now…

I emailed that address 5 days ago - and used the feedback option in the app - no response. Is this usual?

[Edit] This is because the correct email address is service@zoloaudio.com so now we know…

I also just submitted a support case. Cleaned, reset, re-paired, tested with multiple devices, and still no change.

I just experienced this issue with my Kickstarter Gold edition. Reset and clean did not work. They are offering me an exchange for standard black or refund. I’m having a hard time deciding. I loved these until just now. Has anything changed during production to reduce the likelihood of this happening again?

I know they upgraded the mesh grill not sure about hard wear or firmware updates.

Check my post on a fix


Came on here to say that for me at least, this was definitely a hardware and not a software issue.

I thought that the right bud was somehow totally disabled. Tried to reset, repair, and run down the battery to reset, none of which worked. After reading this thread, I checked and realized that no, the right bud was not silent, it was just very very quiet.

I used a pair of electronics tweezers and removed the gold foil. I removed the black cloth strip underneath, and now the right bud has full volume. I put the gold foil back in place. Hopefully it doesn’t fall out inside my ear.

I’m on my 3rd set of earbuds now and it has just become faulty. Disappointing as I thought these ones would be keepers.

Has anyone got a known-good batch or something I could quote when asking for my 4th pair? I’d rather have a working set than a refund, but don’t want a 4th faulty set.

Read my fix Here
It’s not that they are faulty but the rubber/cloth gets gunked up and blocks all sound. Removing it restores full volume

1 Like

I had this problem with my right ear bud. I connected it to my MBP, played music with a lot of bass, and got the Q-Tips and rubbing alcohol. It took 4 Q-Tips to fix. I dipped one end in the alcohol, held the mesh up, applied pressure and rubbed the mesh. Then I flipped it over and rubbed it with the dry end. It started sounding better on the second Q-Tip and was clear and loud after the fourth one. Hope that helps.

I have 2 sets. Both started to get quiet, right earbud first. Q tips fixed them both today!

Elmo - I have to be honest, I thought the cleaning the earbuds fix was bogus. However, I did it last night and removed what looked like a tiny sponge, and with a fingernail cleaned gunk off the gold mesh and it worked! Many thanks!



Your very welcome, glad it worked for you


I have the same problem, but wth the left earbud. Was all working fine and then nearly silent. Your fix of stripping it down and removing something might well work but we should NOT have to. It’s not in the remit or instructions that one has to dissect bits of an earbud every so many hours. It’s ridiculous. I shall be phoning Support on Tuesday. Not happy as it was a great product; now I’m not so sure.

Save from stripping them down you can always clean them with alcohol and a qtip. Let it sit for a bit and then suck on them to force remove any gunk…these headphones are not the only ones to be cleaned this way or have this issue as the earpods do too and if you look it up, they have the same cleaning method

I have the same issue. I’ve tried all suggestions to get this fixed, but still the same issue here.
It looks like a faulty production series?

My Liberty + was bought in January.