WIFI not working with EUFY Home Base

Just installed the Eufy cam and HomeBase which is all working great with the Homebase wired to my router , but I cannot get the HomeBase WIFI connection to work despite running a 2.4G wifi. The wifi network simply does not appear on the EUFY app when I try to connect. Any ideas?

Hi @Drifter and welcome to the community. Does your SSID have any special / reserved characters such as underscores etc?

For anyone struggling for hours with this I found that Eufy Homebase 2 does not work over Wifi if your SSID contains an underscore (_). It probably also doesn’t work with SSIDs containing other non-alphanumeric characters either. I tested this by setting up 2 identically configured SSIDs on my network:

  1. One with an underscore
  2. One without an underscore

After entering the password for each network, and then disconnecting the ethernet cable, the Homebase speaker says “Switching from ethernet to wifi” and then claims “Wifi network successfully connected”. However this is what actually happens:
Case 1) Homebase does not actually successfully connect and the LED become solid red (not solid blue). You can’t then view any video from the Eufy doorbell
Case 2) Homebase does successfully connect to the Wifi network and LED becomes solid blue. Doorbell video streams without issues.

Anker/Eufy really should fix this, or at the very minimum avoid wasting hours of everyone’s time by printing a obvious warning in the App so like: “Sorry, but at this time Eufy cannot connect to SSIDs containing non-alphanumeric characters. The list of available SSIDs has been filtered to exclude any that Eufy is unable to connected to”.

1 Like

That is extremely useful information, thanks for posting. Also email


So they know

And post here which is where Anker wants support discussed.


I just made the same post here:

I also called support to report this a couple of weeks back. Hopefully they will do something to fix this.

1 Like

Thanks for putting in the effort to raise a ticket and to post in their community.

I am getting the same problem but my password only contains one uppercase letter and seven numbers.
Any thoughts appreciated

It’s not your password that matters, it’s the name of your wifi network - ie the SSID. Do you have any non-alphanumeric characters in your SSID?

No, just eight lowercase letters

Investigate password, just alphanumeric.
Invetigate SSID, just alphanumeric
Encryption, ensure WPA / WPA2 , not just WPA2
Firewall, look for reasons it would block connecting.

I have had my 2.4 Ghz network using an (_)underscrore character without any issues for more than 6 months. Homebase 2 talking to a Netgear R7000 router, all with latest firmware. I can plug and unplug it or switch back and forth between Wifi and ethernet and it always connects fine. Maybe it has something to do with the position of the character in the SSID.

Hi there, just wanted to share the following: I had my eufy homebase connected to my tplink deco m9 mesh network over wifi. This worked until recently I started playing with the deco settings, and hit the ‘optimize network’ option. This turned out to be somewhat of a mistake, because after that the homebase would not connect to the deco anymore, and my SSID would not even show up as an option in the eufy app.
I then tried to connect to the wifi of the modem/router provided by my ISP, but was unsuccessful at first. Then I suddenly remembered that some devices are finicky wrt to the wifi channel that is used. I changed the channel of my ISP router wifi from 13 (this is the highest channel in the 2.4ghz range) to 5, and the SSID was immediately visible in the eufy app! Unfortunately the deco m9 doesn’t allow to manually change the channel, so the homebase is now stuck on the ISP router.
So… try changing your wifi channel if you can and if nonstandard characters in your SSID or password were not the issue!