Synology Surveillance Station and eufycam

This doesn’t work for me either (Synology NAS).
Looks like there’s a bug!

it does, but you need to trigger the camera’s recording, not livestreaming through the app.
Click on connect and run through the field of view and you will see, it’s connected.

BUT. Without the trigger of a recording, there is no connection to SurveillanceStation. Currently you are ending up with an error message after each recording, stating you lost connection. Else you can not record through surveillance station.
Only if the camera records, you can grab that clip additionally on surveillance station, which is BS.

The camera should be integrated and responsive by NAS and not only the internal 11 second clips…

No, I tried the recording too, but it doesn’t work.

Version 1.1.3_91 of the newly released Eufy app solves the NAS problem. I’ve updated and it’s working now.

@AnkerSupport Mine still keeps disconnecting even after the app update. At first it seemed like you need to keep the app open to avoid them disconnecting, but after more testing it randomly disconnects whether the app is running in the background or not. Have to toggle the RTSP switch off and on to get it to reconnect. I did manage to get both cameras working for a few minutes until they both disconnected. Looks like eufy have made progress, but still some work to do…

yes, same here. It’s not as often as before but still I can’t keep the connection running and the SurveillanceStation is flooded with error messages…simply not acceptable.

Hi, what has an app update to do with a non working stream from the camera to my nas. It has to be solved with a firmware update or am I wrong?

Just bought a Eufy E security kit (with two cameras) and no trouble to include them with Synology NAS (two different models) with rtsp protocol.

Seems that the camera keep streaming the video for more than 2mn when you activate the rtsp protocol with the App. Then you have time to test connection and save the configuration.

Of course after these 2 minutes you get a message that camera has been disconnected, and at each detected movement you have a couple of “connection restored” and “camera disconnected” (or something like that) on Synology.

Activated videostreaming. Still got “camera test failed”. Bought Eufycam partly because of Synology integration. Disappointed! Suggested RTSP name by app doesn’t match RTSP format suggested by Synology. Anyone can help?

I added two cams to my Synology without problems. To get past the live test, I walked in front of the cam holding my laptop and pressing test when I was sure to be in view.

If you want to re-edit and re-test a camera, make sure though to change the Synology generated url (:########@x.x.x.x:554/live0) back to the Eufy url (x.x.x.x/live0) or your Test Connection won’t work.

1 Like

You should tag @Sestercam

1 Like

hi @eufy_security!

Same here, latest firmware and keeps disconnecting, after adding the camera. I would like to make a big review in Hungary about that, but this really annoying. :hot_face::hot_face::hot_face:

Any beta firmware or something like that?

thats not good. a friend of mine had the same issue.

Any update about that? Still no update or changes. I know its disconnect for battery saveing, but I have a charger, I don’t need to save battery, just always on! Please make it Eufy!

Trying to set up my cameras and having no luck. I installed Surveillance Station 7.1-4155, and when adding a camera can’t get it to connect. Any help would be appreciated.

Has this progressed at all?
I recently bought a EUFY C2 cam, I can get it synced with my synology briefly, then it says connection lost.
I’m guessing the cam remains fairly dormant unless detecting any movement, rather than remaining live constantly.
Has anyone had success either having synology record live for a period of time, or motion detection.
It would be ideal to record onto the homebase but also the synology as well.


The SS integration has turned out to be one of my favorite features of my EufyCam2s (the whole HomeKit integration turned out to be a complete bust for me). The steps outlined above and in the Eufy provided FAQ worked, although it requires a bit of patience. Also note that the cameras will show as disconnected until/unless they detect motion. At first I thought that something was wrong until i began to see the recordings show up in SS as I would expect. While I primarily just use the integration to have a single place to store and review recordings from all of my cameras, I have found it useful as a way to open up Eufy Security to the rest of my home automation. For instance, i have SS create a web hook for motion detection on the cameras to trigger other actions.

Things that i have noticed and wish were improved:

  1. there is a delay between the motion event and the start of the stream in SS. In practice it is not a huge problem as i generally get everything in need in the recording, but it would be nice if it were faster.
  2. There is not way to “activate” the camera from with SS that i can find. This would be extremely useful, not just in setting up the cams, but would allow them to be managed properly as security devices in SS.
  3. SS records all motion events, even if the event is below threshold and would not result in a notification from the Eufy app (I like this feature/bug or whatever). Although it does obey the schedule if you turn the camera off in the app.
  4. I have not found a way to distinguish between a regular motion event, and one that the Eufy AI has determined as human. I have been generally impressed with the human detection capability of these cameras, but since Eufy Security is currently a closed platform (no published API) it is less useful than it could be.

I’m looking into purchasing a NAS so that I can have a higher capacity of storage to my Eufy Cam 2c security system. Which Synology model would you recommend that will work with Eufy? I just don’t know which one to buy.

Any assistance on this will be helpful.

Wish I could help

One of the strangest things is that the records on the HomeBase and the SS are not always the same.

Recordings I see in the app were not recorded by the SS.

Example CAM Frontdoor:
10:31 Motion detected, recording on Homebase and SS
10:38 Motion detected, recording only on Homebase