(Solved!) Roav Bolt Not Triggering Google Assistant

Bolt is still finicky with calls. Sometimes it routes the call correctly when placing but it never routes call when receiving.
Fyi this is for iOS

1 Like

I’d probably stay away from this charger until all the problems are fixed

My somewhat similar issue was resolved after making sure the Google, LLC app was up to date. For initial trouble shooting, I followed @Nebulous_Noob 's advice post on how to completely erase all Bluetooth history and then found the Google, LLC & Google Assistant apps to Update before having to Uninstall and Reinstall them.

Thanks, @Nebulous_Noob!

Are you able to make calls on your iPhone without actually pressing the call button on the phone? ((After you’ve said the command)

On Android hear and okay Google and the Assistant button do not activate the Bolt, but audio and calls do pass through to the aux cable. I tried the enable spoken notifications and activate from BT headsets, but it still does not work.

Just an update they have confirmed this is device / os specific with my Axon 10 Pro. Working with support and Google for a fix.

Still broken, but have now been told my phone is not popular enough so might not get fixed.

Worked for me I have an OnePlus8. Thank you! I was starting to regret my purchase.

This is what solved it for me on my Samsung phone.
I enabled the hit word detection in android auto and it worked instantly.


Hopefully this can help other user, good job :+1:

Also, make sure your phone is not paired with another Bluetooth audio device such as your car.

1 Like

I signed up ONLY to say THANK YOU!!! I’d lost hope on this device and put it away, but now it’s working again. :+1:

This is my 2nd Roav Bolt. I loved the old one. Even being in tech and software for decades, the original Roav Bolt took me over 2 hours to set-up. But loved it when working.

It broke on me about 2-weeks ago. I literally spent over 4-hours watching YouTube vids and trying everything. So I figured it was broken and bought a new one. Now I am reading that it wasn’t likely the Bolt hardware, but a problem with software versions.

I went through the complete setup and every step said successful. However, just like the OP, I couldn’t access Google Assistant through voice commands in car. I could through the phone.

So it looks like I just spent $60, including taxes and shipping, to buy a new one that I did not need. I NEED A SOLUTION and money refunded asap pls.

Frankly, Anker took a satisfied customer and turned him into a cynic who is just about ready to trash Anker all over the Internet. I ran software companies for 20-years. To not deeply check compatibility thoroughly with new versions of operating systems that are required, is terrible product development.

Since I am unnecessarily out $60, can Anker actually step me through this with a person on the line and me in my car? After releasing a product with very poor QA and Exceptionally poor setup, can I pls have someone walk me through this step by step?

I know those of you at Anker in Tech Support have zero fault with these product killer problems. In fact, the poor product, poor QA and poor setup instructions are causing all of you in support massive headaches and late nites. I want to thank all of you.

Dan Hilbert
CEO Proffitz Inc

Clarification. I only paid $35 for this new one. I can now see why almost all sellers are majorly discounting this Anker product.

Hello folks. I know this thread is a year old but I was hoping someone could still help me.

As like everyone here, I now have a problem reinstalling my Roav Bolt after I accidentally removed it from my bluetooth device list. This happened to me before and the only solution for an iphone was to format your iphone and google assistant discovers again the “SETUP CARD” so you can install the BOLT. I tried everything the tech support told me before which was to delete the google assistant app and reinstall, reset the ROAV BOLT by pressing 12-15 seconds, removing and reinstalling GOOGLE APP and GOOGLE LLC. But the only thing that really worked was when I completely factory reset my phone. This somehow I guess deletes something on your phone that the google assistant or Roav doesn’t like when reinstalling.

Note that I tested this with another iphone I have. Fresh install of ROAV BOLT to this other iphone and google assistant discovered the “SETUP CARD” and I was able to install it. Then I removed it from bluetooth device list just to test if it will do the same thing. Guess what? It did the same thing, it won’t discover it anymore from google assistant setup. So for some reason, the ROAV BOLT on iphones are having trouble when it gets removed, you won’t be able to reinstall it unless you format your iphone. Something in your iphone is preventing it from being reinstalled once it is already previously installed. It seems like in android, there’s a way to completely removed all bluetooth history data or something, maybe this is the case with iphones as well but we just don’t have that option to remove some hidden data? Why would reformatting your phone fix the issue? So there is some data that either google assistant or ROAV BOLT stores in your phone, that when you reinstall, it has to be removed completely. Please help me. I contacted ROAV already about this but none of their responses helped. Please help me? thank you!