Persistent drop sensor issue in spite of cleaning

So, while cleaning today, my Robovac 11 hit a chair and stopped. When I tried to restart it, the red light was flashing and there were 3 beeps. So I cleaned the drop sensors thoroughly, but the issue hasn’t gone away. Even manual directions are not working. The brushes are rotating, but the wheels won’t spin.

What other things should I try?

1 Like

@Anup_S, sorry to hear the inconvenience our RoboVac 11 caused. Please be assured that we always stand behind our products and we are happy to assist you with an exchange if the problem turns out to be with it.

We understand you have tried the solutions, but could you please also tap the bumper and wheels to see whether they are stuck? And if necessary, remove any hair and debris from them.

If the issue can’t be fixed, could you please contact us via""? We will help you replace or return it once we confirmed your issue and your order detail.

Lastly, there is a gap between the six sensors on the Robovac’s bumper, so it sometimes can’t sense the thin chair/table leg. Sorry about that, but we will forward this issue to our Product Team to make it better in the future.

Appreciate your time and we look forward to hearing from you.

Hi! Thanks for your reply. I tried the things that you suggested. Everything seems fine. The bumper has it’s normal action and the wheels are completely fine. As I bought it in India on Amazon, I’ve contacted the seller directly for the replacement. Is that okay?

1 Like

Ok I’ve been having issues with this, done all the steps, seemed fine, but always started thinking they were broken…when it was in sunlight!

Turns out, I think the reflection of intense sun on the lino scrambles the sensors a bit, so I guess my RoboVac is a some sort of vampire.

Closed the curtains and it works flawlessly.