Nebula Cosmos and Cosmos Max Issues & Resolutions

Hello. there,
I bought the cosmos max because I am really satisfied with my capsule max that I use in my camper.
Anyway, there a few annoying issues with the cosmos max, some of them already mentioned in the discussion above.
How do I get multichannel audio from the projector to my avr? I tried HDMI ARC, toslink and Bluetooth, they all seem to put out stereo only. Did anyone here manage to get any kind of multichannel audio from this?
Thank you, kind regards Martin

Hello, i have the same problem you mention regarding the remote being unable to wake up the Cosmos.
Before the update to version 9.0.49 it never occurred (on the same day I received a notification regarding an update available for the remote ver. 2.0.0.16, and i applied this as well).

Since I updated I’m not able to wake the device via remote, just with the button on the back of the unit…

Has this issue been solved?
Thank you

Meil’s, I sent my projector back and they replaced it with a new unit. The new unit no longer has the issue. It could not be solved via software and required a replacement under warranty. Anker was fast and responsive in replacing the unit.

Thank you for your reply bformato,
I’ll contacts Anker support.
Bye

Hello,
I contacted Anker support detailing the situation and they replied that they did internal tests and they have reproduced the situation.
They say that they will have this issue fixed within the next firmware version, apparently in 10 days or so.

A quick fix is to unpair the remote bluetooth link to the unit, thus using the infrared instead.

Fingers crossed :slight_smile:

1 Like

Did someone measure the power consumption of the cosmos max? Mine uses up to125W when running, 25W when in standby and about 20W when powered off. Last two numbers are far too high and I hope, my measuring unit is faulty.

When its powered off do you still hear the fans running? As that could explain the power draw

No, no fan no light, etc…

Update.
Yesterday the new version of the firmware was released for the Nebula Cosmos (v. H2_9.0.52), and the remote control issue was solved.
:+1:

1 Like

The measuring device was faulty. The new one shows 0.2W so everything is fine.

Hi everyone, so far the projector has been decent. I really wish there was EQ for the built in speakers. This I feel is a big issue because of my unit barely has any bass and the highs are too loud. Also, has anyone else had the issue of the flashing white lines that come on the screen. Every time this happens I have to restart the projector and hope it doesnt happen again.

I did some research on ways to remotely turn the Nebula Cosmos Max on/off and came across the following options:

1. ADB (Android Debug Bridge)
Requires a USB connection to a Mac, Windows or Linux PC and Google’s ADB tool (part of the Android Development software). Entering adb devices in the Terminal window should list the projector as D2150something. Entering adb shell input keyevent KEYCODE_POWER switches the projector on or off.
The big BUT: The projector shows itself only to the ADB after it has gone through a Android booting process/power cycle, which means that when connecting the projector to the power cord for the first time, none of the above ADB commands will work. Instead you have to grab the IR handheld remote control and turn the projector on, so that Android has launched at least once. Now ADB is setup, you can turn it off AND on via ADB.
ADB per se also can be used via TCP/IP (which includes WLAN connections), but to set that up permanently, SU or root access is required, which the Android on the Nebula Cosmos Max doesn’t allow.

2. Bluetooth
The Nebula Connect App for iOS and Android has a prominent Power button which works via Bluetooth (and if not signed, might be possible to mimic using other Bluetooth transmitters). The big problem: Just like ADB, Bluetooth communication isn’t available when the projector gets connected to power, but instead requires the Beamer’s Android OS to be launched at least once.

3. Infrared
Works at all times, also when fresh powered, without Android boot cycle. Uses NEC Infrared Transmission Protocol, code 10EF50AF. So when using the ESPEasy with plug-in 016 Infrared Transmit the http request is http://ip_address_of_the_ESP8266/control?cmd=IRSEND,NEC,10EF50AF.
Annoying: The Nebula Cosmos Max uses some of the same commands as my nearby Logitech Z-5500 surround amp. Projector On/Off = Analogue Input selection on Z-5500. Volume Up on Z-5500 = Projector settings menu.

Hi, have had our nebula cosmos max for 1 year and now we can only hear sound and we only can view a green screen…kind regards Family Barker

[quote=“meindefy, post:21, topic:85092”]
How do I get multichannel audio from the projector to my avr? I tried HDMI ARC, toslink and Bluetooth, they all seem to put out stereo only. Did anyone here manage to get any kind of multichannel audio from this?
[/quote] - I have same issue. Was anyone able to resolve this issue?

I have to agree and count myself as a very disappointed customer. I have other Anker products which have always lived up to expectations, but after spending roughly $600 on the Nebula Cosmos 1080, I am very disappointed with image quality. I will not go into some of the issues such as color banding at the corners and fuzzy focus/detail, because the issues that really peeve me the most are: 1) Washed out dark scenes, no matter what the source is (HDMI, web, USB drive) and no matter what picture setting I use; 2) VERY poor streaming image quality, even though my house has fiber and a very fast WiFi router which is less that 10 feet away from the Cosmos. I feel like I’ve been fooled and am looking into how I can return this. Somewhere I saw there is a 30-day return policy, does this apply to purchases on Amazon or only directly from Anker?

I have the same issues with my Cosmo Max 4K. I can’t get multichannel passing through (Dolby Digital +) when connected to the ARC of my receiver. I have tried to change the audio settings to get auto PCM to RAW bitstream and it does not work. Whenever I switch to auto and play a show on Prime, all I hear is hissing sounds. I was wondering if someone has come with a solution?

My solution: Get a nvidia shield and use the projector just to display the shield’s screen.

Did you connect your streaming device directly to your AVR HDMI and use the Cosme only to stream video? I have tried with my FireSticK with no success. I even tried the optical Audio with no success (same issue when setting sound to RAW). I haven’t tried to cast from my phone, though. Maybe I should try to see if I can get MC audio?

Yes. Shield connected to AVR whoms HEMI out goes into Cosmos HDMI in.