Eufy robovac 11



My Robovac does not seem to be charging - how do I check the health of the battery. This unit is less than 6 months old


As per the manual try cleaning the charging pins

Also make sure no objects are 3 feet on the side or 6 feet in front of the unit


thanks - I will try and clean the connections. It is docked correctly and the light is blue. It just doesn't start. If it is not the battery then any other ideas?


If all else fails contact eufy via one of these methods below. If you email them make sure to provide serial number, proof of purchase and anything that can help expedite your support and or warranty exchange if need be.


Hi patrick.dennin, we are sorry your RoboVac can't be charged. Please be assured we will help you out.

From your description, it seems the side switch has been turned off.(see the attachment) Could you please check it?

If not, would you charge it directly from the AC adapter without the charging base for 5+ hours and retry? Also, please let us know whether or not the charging indicator lights up when you charge it this way.

If the issue can't be solved, please contact us via our email for additional troubleshooting.


Hi Patrick. I have the same problem with your robovac. Did you solve your problem? If you got it, pls instruc me that how to solve. Thank you so much!


@van_vu_hoang Sorry to hear that. Did you try the solutions AnkerSupport has provided above? If it's still not working, would you mind contacting our customer service with your serial number and order number via directly? I'm sure they will help you out. :relaxed: