Wifi connection RoboVac L70 & Fritzbox 7530

Hello
I have the following problem.
I’m trying to set up my Eufy L70 with the EufyHome App, but it doesn’t work.
Smartphone is connected to the router (fritzbox 7530). The correct router is selected in the EufyHome app and the password is correct.
The L70 is found and when trying to connect it says that the smartphone and robot are not connected to the same network.
I started the mobile hotspot via another device and the connection would have worked here.
So it has to be a router setting. I have already deactivated the 5 GHz band and switched the radio channel to 802.11b + g + n (Wi-Fi 4) in the settings.
Still no connection possible.

unfortunately I don’t know what to do next and therefore ask for help.

I translated through Google because my English is not good enough. So sorry for the English.

thank you in advance.

Greetings
Davide :slight_smile:

Is both your phone and RoboVac using the same 2.4Ghz SSID?

Thank you for your answer.
yes, both are connected to the same ssid and the password is correct.
5 Ghz is switched off.
I also tried to enter the MAC address of the robot in the settings of the router and to enable the ports, but I had the feeling that this had not worked because it could not assign the Mac address to any device.
I also tried to equate the wifi channel of the router with that of the robot, but that didn’t work either. I tried to change the name of the router (even if the EufyHome app always found the router)
I really don’t know what else to adjust.