Wifi Connection robovac 30c Connection error IPhone

I am having issues with connecting to the app (iPhone) with my Robovac 30c. I have tried the following:

  • turning off 5ghz on router.
  • aeroplane mode on phone.
  • resetting device
  • trying app on alternative device
  • resetting router

Of course holding the reset button on the vac every time and attempting to reconnect to the app. The Robovac appears in the WiFi list but when I connect and return to eufy home App it always shows a „Connection error - please connect to your eufy device“.

Have emailed the support@eufylife.com no response as of yet so thought I would try the forums.

1 Like

Try using the 2.4Ghz and try changing the SSID encryption password, give it a try. It happened to one of my smart plugs… change of password fixed it.

Also check on what Eufy Support has got to say, and post the update what you hear

I have the same issue as the original poster with a 15C. Pretty much tried everything he said including two different iPhones and an iPad.

In another thread, it was suggested to try putting your phone into “Airplane mode,” then enable Wifi only (in effect, you’re disabling Bluetooth and cellular data on your phone). Then, try to connect to Eufy’s Wifi network with only Wifi enabled on your phone. Give it a shot and see if it helps!
Otherwise, feel free to reach out to the Eufy support team: https://www.eufylife.com/contact

1 Like

What actually worked was setting up the WiFi and everything else via a Amazon fire tablet… when i used the tablet, everything went smoothly as it should. I have no idea why it didn’t work with the iPhone / iPhones I tried. Fun fact is: I logged into the app with my phone after set up was successful via the amazon Fire and now I can use the app on my phone as well.

Again, not a clue why, after I tried various other options and basically all suggestions I could find.

Thank you all anyway and I hope this does not happen to too many people!

Same WiFi situation here, but used a Samsung Galaxy Tab A to connect to a RoboVac 15C Max. Once connected, re-logged into the phone app and all is well.

I did same with ipad, Altho in a room further away from router