Soundcore Life Q30 Headset (Hands-Free) doesn't work in Windows 10

For some reason on my laptop with Intel Wireless-AC 9560 board I cannot use Soundcore Life Q30 (latest firmware 1.90) headphones in headset/hands-free mode. Neither audio plays, neither microphone works. Thus, I have updated bluetooth drivers to the latest version from Intel website. Of course, that didn’t help. Still programs like Zoom, Microsoft Teams still give me an error. I tried many times unpairing and resetting headphones, installing legacy Bluetooth drivers, but the problem still persists. Additionally, thein I do audio troubleshooting in Windows 10. Troubleshooter writes that there are no corresponding drivers installed for this headset mode.

Furthermore, headphones work perfectly using an Android smartphone.

3 Likes

You could do a search here by using the magnifier option regarding you issue.
But there is another forum where more earbud users participate :

https://community.soundcore.com/chat

I am sure you will get help there.

1 Like

As @Chiquinho points out, the soundcore community is a good place to check.

Be aware that this issue is not uncommon across all of the headsets, and you may find tips if you also search for “zoom” or “teams”.

I’ve had issues with my Q10s, and have resorted to using stereo mode on the headset and laptop mic for speech.

We need a FAQ and guide thread for Windows 10, the little evil Richmond bugger is causing a lot of woes. :imp:

Everyone move to Android.

Apparently :slight_smile:

Windows 10 owners have to write such a guide, write up symptoms and screenshots of what fixes it.

Anyone?

com-add-text(41)

2 Likes

I always suggested that… :roll_eyes:

Over in Reddit there’s some users giving up on Windoze’s awful bluetooth, it is too unreliable, and moving to wired, they still use Q30 but use an inline microphone as the Q30 don’t have 4-pole mic port. If that’s a proven solution, a write-up screenshot would be useful.

I just use Linux or Android so I have nil hands-on experience to help here other than search like anyone else can.

The virus forcing work from home has forced people to blend work / pleasure needs into one device, Win10 and headphones, ANC helps to concentrate in WTH so fully understand how the problem arose, Microsoft made an awful OS and its being forced on people for work reasons and we are here.

The common reason work forces Win10 is for a full Office environment, such as a full Outlook client. Android don’t have such a full Office so it’s hard to force work into Android. The Win10 bluetooth problem needs focused Win10 owners to cooperate to write a guide. Once written, we force it to get top of search.

2 Likes

Before posting here I read through this forum and ‘chat community’. I found couple people who this issue with Q30 or older models. So this is not commom issue compared to low quality MIC audio. So I wrote this post to bump the issue. I hoped that someone figure out a fix.

2 Likes

Not your fault. Someone who has the fix needs to invest the time doing a write-up. It’s not specific to Anker / Soundcore, it’s specific to Windoze.

I’ve seen some success with replacing BT drivers but also give up on Windoze bluetooth and move to wired with an inline microphone.

Windoze? , we here were used to say Windoofs :rofl:

2 Likes

The same problem here. With 01.80 everything works fine with Win10 and Teams/Skype. After the Update to 01.90 “Soundcore Life Q30 Hands-Free AG Audio” Mic and Sound have a terrible quality. “Soundcore Life Q30 Stereo” is only available by sounds and doesn’t work with ms Teams/Skype.

3 Likes

I have the same problem.
I just bought the headset Q30 to help me during my daily work calls/meetings on MS Teams. When paired with PC, for sound I have two options: one is the Headset (Soundcore Life Q30 Hands-Free AG Audio) and the other is Headphones (Soundcore Life Q30 Stereo), but only the Headset (Soundcore Life Q30 Hands-Free AG Audio) works with MS Teams although the sound and Mic is terrible, the sound seems like popcorns are jumping and my coworkers say my sound is very metallic and not good.
I have updated the Life Q30 firmware for version 1.90, also the Bluetooth drivers but I still have the same problems.
Does anyone know how to deal with this?
Thank you

1 Like

Investigate your device drivers further and Bluetooth settings.

I know this is for Q10 but the issue is specific to Windows not specific to Soundcore so the guide is usually applicable for other products.

1 Like

We had raised a call with service regarding the Q10s and using with teams. Was politely advised that the Q10s were not certified to work with teams.

Alas, did a work around using laptop as mic source and stereo setting on laptop to use the headphones. Both 3 pole cord and BT.

1 Like

same same! connection is fine, headphones mode works (bad quality), but not the headphones mode

ah, disabling “Bluetooth Device (RFCOMM PROTOCOL TDI)” fixed it for me. Headset mode is gone though…

Same problem here. ;(

Oh same problem. q30 not detected by windows 10 laptop.

Use the magnifier option to find some suggestions.
Also there is a forum from soundcore.
There those problems are discussed quite every day.

The solution. Reset and it works now for both my android phone and win10 laptop. :joy::joy: